summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorÉtienne Deparis2015-06-29 10:00:08 +0200
committerÉtienne Deparis2015-06-29 10:00:08 +0200
commit9bedc1dd0ae7463fa12dcf1d53b0823f47f7fffa (patch)
tree7f2f54f05b0fa686d174fb68b9d31e3a7b0a4164
parent06182b12cfb4d69f75bb835957a577de83fc34c9 (diff)
downloadaur-9bedc1dd0ae7463fa12dcf1d53b0823f47f7fffa.tar.gz
New pkgbuild version
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD17
2 files changed, 11 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d01c8c3ed39e..a2c20b3a73af 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,16 @@
# Generated by makepkg 4.2.1
-# Wed Jun 3 14:10:39 UTC 2015
+# Mon Jun 29 07:53:41 UTC 2015
pkgbase = khal-git
pkgdesc = Command line CalDav client
- pkgver = 0.6.0.r2.g0e7045c
+ pkgver = 0.5.1.dev53+ng56cb1f0
pkgrel = 1
url = http://lostpackets.de/khal/
install = khal.install
arch = any
license = MIT
makedepends = python-setuptools
+ makedepends = python-setuptools_scm
+ makedepends = python-pkginfo
makedepends = git
makedepends = python-sphinxcontrib-newsfeed
depends = python-urwid
diff --git a/PKGBUILD b/PKGBUILD
index 088f36ecc072..eb0b56cc781d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,16 @@
pkgname=khal-git
_gitname=khal
-pkgver=0.6.0.r2.g0e7045c
+pkgver=0.5.1.dev53+ng56cb1f0
pkgrel=1
pkgdesc="Command line CalDav client"
license=("MIT")
url="http://lostpackets.de/khal/"
depends=('python-urwid' 'python-xdg' 'vdirsyncer' 'python-dateutil'
- 'python-configobj' 'python-tzlocal' 'python-icalendar' 'sqlite')
-makedepends=('python-setuptools' 'git' 'python-sphinxcontrib-newsfeed')
+ 'python-configobj' 'python-tzlocal' 'python-icalendar'
+ 'sqlite')
+makedepends=('python-setuptools' 'python-setuptools_scm'
+ 'python-pkginfo' 'git' 'python-sphinxcontrib-newsfeed')
optdepends=('python-setproctitle: Display a clearer name in your process list')
# I keep here python depencies...
# python2-click, python2-icalendar come with the python2-vdirsyncer dependancy
@@ -30,13 +32,8 @@ arch=('any')
options=(!emptydirs)
pkgver() {
- cd "$srcdir/${_gitname}"
- MAJOR=`sed -n "s/MAJOR\s\?=\s\?\(\d*\)/\1/p" version.py`
- MINOR=`sed -n "s/MINOR\s\?=\s\?\(\d*\)/\1/p" version.py`
- PATCH=`sed -n "s/PATCH\s\?=\s\?\(\d*\)/\1/p" version.py`
- GITVER=`git describe --always --dirty --tags | cut -d- -f2- | sed -r 's/([^-]*-g)/r\1/;s/-/./g'`
-
- echo "${MAJOR}.${MINOR}.${PATCH}.${GITVER}"
+ cd "$srcdir/${_gitname}/"
+ python -c 'import setuptools_scm; print(setuptools_scm.get_version())'
}
build(){