summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortaotieren2024-04-08 21:27:50 +0800
committertaotieren2024-04-08 21:27:50 +0800
commitf8459d0a2c44aae12ca8364b6e6ffff374ef4c55 (patch)
tree2bab632a111774de4fbbe8643df47ddd26a9834e
parentb47fbd5604fdb15256693e337200cd44705493b9 (diff)
downloadaur-kibot.tar.gz
Add kibot
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD28
2 files changed, 29 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a72b209e9f2a..227e50548fde 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,16 @@
pkgbase = kibot
pkgdesc = KiCad automation utility
- pkgver = 2
+ pkgver = 1.6.5
pkgrel = 1
url = https://github.com/INTI-CMNB/KiBot
arch = any
- license = GPL-3.0
+ license = AGPL-3.0-or-later
checkdepends = python-pytest
+ makedepends = python-build
+ makedepends = python-installer
makedepends = python-setuptools
+ makedepends = python-wheel
+ makedepends = git
depends = blender
depends = ghostscript
depends = git
@@ -39,9 +43,10 @@ pkgbase = kibot
optdepends = kicad-interactivehtmlbom: Interactive HTML BOM generation plugin for KiCad
optdepends = kicad-library: KiCad symbol, footprint and template libraries
optdepends = kicad-library-3d: KiCad 3D model libraries
+ provides = kibot
+ conflicts = kibot
conflicts = kibot-git
- options = !strip
- source = kibot-2.tar.gz::https://github.com/INTI-CMNB/KiBot/archive/refs/tags/v2.tar.gz
- sha256sums = 2d0881c0df5e3e61b1e461d04a0ae3c927eb0da3952733caf668b4887d84d748
+ source = KiBot-1.6.5.tar.gz::https://github.com/INTI-CMNB/KiBot/archive/refs/tags/v1.6.5.tar.gz
+ sha256sums = acc6dab74d446bf5bb7444a9fef34cb31ea231a92ef5f3aa6c17b3ded38ace89
pkgname = kibot
diff --git a/PKGBUILD b/PKGBUILD
index e36e54098df7..97d311e8b43e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: taotieren <admin@taotieren.com>
pkgname=kibot
-pkgver=2
+pkgver=1.6.5
pkgrel=1
epoch=
pkgdesc="KiCad automation utility"
arch=('any')
url="https://github.com/INTI-CMNB/KiBot"
-license=('GPL-3.0')
+license=('AGPL-3.0-or-later')
groups=()
depends=(
blender
@@ -40,24 +40,34 @@ depends=(
python-yaml
xorg-server-xvfb
)
-makedepends=("python-setuptools")
+makedepends=('python-build'
+ 'python-installer'
+ 'python-setuptools'
+ 'python-wheel'
+ 'git')
checkdepends=(python-pytest)
optdepends=('kicad-interactivehtmlbom: Interactive HTML BOM generation plugin for KiCad'
'kicad-library: KiCad symbol, footprint and template libraries'
'kicad-library-3d: KiCad 3D model libraries')
-provides=()
-conflicts=(kibot-git)
+provides=(kibot)
+conflicts=(kibot kibot-git)
replaces=()
backup=()
-options=('!strip')
+options=()
install=
changelog=
-source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/refs/tags/v${pkgver}.tar.gz")
+source=("KiBot-${pkgver}.tar.gz::${url}/archive/refs/tags/v${pkgver}.tar.gz")
noextract=()
-sha256sums=('2d0881c0df5e3e61b1e461d04a0ae3c927eb0da3952733caf668b4887d84d748')
+sha256sums=('acc6dab74d446bf5bb7444a9fef34cb31ea231a92ef5f3aa6c17b3ded38ace89')
#validpgpkeys=()
+build() {
+ cd "${srcdir}/KiBot-${pkgver}"
+ python -m build --wheel --no-isolation
+}
+
package() {
cd "${srcdir}/KiBot-${pkgver}"
- python setup.py install --no-compile --root="$pkgdir"
+ # python setup.py install --no-compile --root="$pkgdir"
+ python -m installer --destdir="${pkgdir}" dist/*.whl
}