summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormaz-12015-10-19 19:37:44 +0800
committermaz-12015-10-19 19:37:44 +0800
commit482e0027d35e5c9910da94703cb565f7332e6f1b (patch)
treea244fee82521344acc6354619a30902a2191eba1
parenta2259e5c32d30ef308b675a947ed81f9563916b5 (diff)
downloadaur-kio-locate-kf5.tar.gz
fix
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD3
-rw-r--r--port_to_qt5.patch26
3 files changed, 22 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0e8e5a05ff7e..002c6796c7b3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -15,7 +15,7 @@ pkgbase = kio-locate-kf5
source = port_to_qt5.patch
md5sums = 198b43f6c873863bd02113db0ffe29bb
md5sums = 270660f80c69d3a6b0a39dbdbaf672eb
- md5sums = 28716a4a26b0136215ddb97e3a3ed5f6
+ md5sums = SKIP
pkgname = kio-locate-kf5
diff --git a/PKGBUILD b/PKGBUILD
index b576e8288765..8f679b22a758 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,7 +15,7 @@ source=("http://kde-apps.org/CONTENT/content-files/120965-$_pkgname-$pkgver.tar.
"port_to_qt5.patch")
md5sums=('198b43f6c873863bd02113db0ffe29bb'
'270660f80c69d3a6b0a39dbdbaf672eb'
- '28716a4a26b0136215ddb97e3a3ed5f6')
+ 'SKIP')
prepare() {
@@ -37,4 +37,5 @@ package(){
make DESTDIR=$pkgdir install
mv "${pkgdir}/usr/lib64/plugins"/* "${pkgdir}/usr/lib/qt/plugins"
rm -r "${pkgdir}/usr/lib64"
+ install -Dm644 ../kio_locate.kcfg "${pkgdir}/usr/share/config.kcfg/kio_locate.kcfg"
}
diff --git a/port_to_qt5.patch b/port_to_qt5.patch
index 9168d452ee5e..9c9dae773ddc 100644
--- a/port_to_qt5.patch
+++ b/port_to_qt5.patch
@@ -1,7 +1,7 @@
diff -Naur a/CMakeLists.txt b/CMakeLists.txt
---- a/CMakeLists.txt 2015-10-19 18:58:41.354638945 +0800
-+++ b/CMakeLists.txt 2015-10-19 18:47:06.210782022 +0800
-@@ -1,14 +1,23 @@
+--- a/CMakeLists.txt 2010-03-07 02:38:40.000000000 +0800
++++ b/CMakeLists.txt 2015-10-19 19:28:48.185748034 +0800
+@@ -1,31 +1,38 @@
set(KDE_MIN_VERSION "4.4.0")
-find_package(KDE4 4.4.0 REQUIRED)
-include (KDE4Defaults)
@@ -19,8 +19,8 @@ diff -Naur a/CMakeLists.txt b/CMakeLists.txt
add_definitions(-DKDE_DEFAULT_DEBUG_AREA=7199)
- include_directories( ${KDE4_INCLUDES} )
- include_directories( ${KDE4_KIO_INCLUDES} )
+-include_directories( ${KDE4_INCLUDES} )
+-include_directories( ${KDE4_KIO_INCLUDES} )
-macro_optional_add_subdirectory(doc)
-macro_optional_add_subdirectory(po)
@@ -29,8 +29,20 @@ diff -Naur a/CMakeLists.txt b/CMakeLists.txt
set(kio_locate_PART_SRCS
pattern.cpp
-@@ -25,7 +34,7 @@
- kde4_add_plugin(kio_locate ${kio_locate_PART_SRCS} ${kio_locate_PART_RCCS})
+ kio_locate.cpp
+ locater.cpp)
+
+-kde4_add_ui_files(kio_locate_PART_SRCS
++qt5_wrap_ui(kio_locate_PART_SRCS
+ klocateconfigfilterwidget.ui
+ klocateconfiglocatewidget.ui
+ klocateconfigwidget.ui)
+
+-kde4_add_kcfg_files(kio_locate_PART_SRCS klocateconfig.kcfgc)
++kconfig_add_kcfg_files(kio_locate_PART_SRCS klocateconfig.kcfgc)
+
+-kde4_add_plugin(kio_locate ${kio_locate_PART_SRCS} ${kio_locate_PART_RCCS})
++add_library(kio_locate MODULE ${kio_locate_PART_SRCS} ${kio_locate_PART_RCCS})
-target_link_libraries(kio_locate ${KDE4_KDE3SUPPORT_LIBS})