summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2018-09-27 16:17:47 +0000
committerDaniel Bermond2018-09-27 16:17:47 +0000
commit295e1eb65ad4b9356f6fff222728ddd09c9cb982 (patch)
treed5e9b836d260bf980cd84ec0ef5979d1cd188f68
parenta5fc166350b2e929c228ceebe024741b21345a00 (diff)
downloadaur-295e1eb65ad4b9356f6fff222728ddd09c9cb982.tar.gz
Fix build and packaging
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD68
-rw-r--r--kitematic.desktop5
-rw-r--r--kitematic.install8
4 files changed, 53 insertions, 45 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 57b6e0cae6ca..15d438241442 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,22 @@
pkgbase = kitematic
pkgdesc = Visual Docker Container Management
- pkgver = 0.17.3
+ pkgver = 0.17.3+10+g26abc33e
pkgrel = 1
- url = https://github.com/docker/kitematic
+ url = https://github.com/docker/kitematic/
arch = x86_64
- license = Apache
+ license = APACHE
makedepends = git
makedepends = npm
- makedepends = nodejs-grunt-cli
+ makedepends = grunt-cli
depends = docker
- depends = nodejs
- conflicts = kitematic
- source = kitematic::git+https://github.com/docker/kitematic.git
+ depends = nodejs-lts-carbon
+ depends = glib2
+ depends = hicolor-icon-theme
+ source = kitematic::git+https://github.com/docker/kitematic.git#commit=26abc33e61fd1535762c1813d9130e55789dbe85
source = kitematic.desktop
source = kitematic.svg
sha256sums = SKIP
- sha256sums = 448603660a205037c83125759e523cfec9cf1a93c0b1317482740a04292d5bdc
+ sha256sums = acf85b7e6a94be11c482f6119dcea00cf828d9cd25e0bdea22b844fa5d4c01c0
sha256sums = 954d9803f49e475bc3242ad8b5dbfe5f3be9b532434ff260e1cf5c929f018617
pkgname = kitematic
diff --git a/PKGBUILD b/PKGBUILD
index 10945f2daef8..b2e86b5de2b9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,52 @@
-# Maintainer: Alessio Fachechi <alessio.fachechi@gmail.com>
+# Maintainer : Daniel Bermond < yahoo-com: danielbermond >
+# Contributor: Alessio Fachechi <alessio.fachechi@gmail.com>
+
+# fix segmentation fault
+_commit='26abc33e61fd1535762c1813d9130e55789dbe85'
pkgname=kitematic
-pkgver=0.17.3
+pkgver=0.17.3+10+g26abc33e
pkgrel=1
pkgdesc='Visual Docker Container Management'
arch=('x86_64')
-url='https://github.com/docker/kitematic'
-license=('Apache')
-depends=('docker' 'nodejs')
-makedepends=('git' 'npm' 'nodejs-grunt-cli')
-conflicts=('kitematic')
-source=(
- "$pkgname::git+https://github.com/docker/kitematic.git"
- "$pkgname.desktop"
- "$pkgname.svg"
-)
-sha256sums=(
- 'SKIP'
- '448603660a205037c83125759e523cfec9cf1a93c0b1317482740a04292d5bdc'
- '954d9803f49e475bc3242ad8b5dbfe5f3be9b532434ff260e1cf5c929f018617'
-)
+url='https://github.com/docker/kitematic/'
+license=('APACHE')
+depends=('docker' 'nodejs-lts-carbon' 'glib2' 'hicolor-icon-theme')
+makedepends=('git' 'npm' 'grunt-cli') # needed for next version: 'typescript' 'tslint'
+source=("$pkgname::git+https://github.com/docker/kitematic.git#commit=${_commit}"
+ 'kitematic.desktop'
+ 'kitematic.svg')
+sha256sums=('SKIP'
+ 'acf85b7e6a94be11c482f6119dcea00cf828d9cd25e0bdea22b844fa5d4c01c0'
+ '954d9803f49e475bc3242ad8b5dbfe5f3be9b532434ff260e1cf5c929f018617')
+
+pkgver() {
+ cd "$pkgname"
+
+ git describe --long --tags | sed 's/^v//;s/-/+/g'
+}
build() {
- cd "$pkgname"
- git checkout tags/v$pkgver -b $pkgver
- npm install
- grunt babel less copy:dev shell:linux_npm electron-packager:build
+ cd "$pkgname"
+
+ npm install
+
+ grunt babel less copy:dev shell:linux_npm electron-packager:build
}
package() {
- install -dm755 "$pkgdir"/{opt,usr/bin}
- install -Dm644 "$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
- install -Dm644 "$pkgname.svg" "$pkgdir/usr/share/icons/hicolor/scalable/apps/$pkgname.svg"
-
- cp -R "$pkgname/dist/Kitematic-linux-x64/" "$pkgdir/opt/$pkgname"
- ln -s "/opt/$pkgname/Kitematic" "$pkgdir/usr/bin/kitematic"
+ cd "$pkgname"
+
+ install -d -m755 "$pkgdir"/{opt,usr/bin}
+
+ # install files
+ cp -aR dist/Kitematic-linux-x64/ "${pkgdir}/opt/kitematic"
+
+ # create symlink for binary
+ ln -s ../../opt/kitematic/Kitematic "${pkgdir}/usr/bin/kitematic"
+
+ # desktop file and icon
+ cd "$srcdir"
+ install -D -m644 'kitematic.desktop' -t "${pkgdir}/usr/share/applications"
+ install -D -m644 'kitematic.svg' -t "${pkgdir}/usr/share/icons/hicolor/scalable/apps"
}
diff --git a/kitematic.desktop b/kitematic.desktop
index fba6458ee93b..9ff21c4f2786 100644
--- a/kitematic.desktop
+++ b/kitematic.desktop
@@ -1,8 +1,9 @@
[Desktop Entry]
-Type=Application
+Version=1.0
Name=Kitematic
Comment=Visual Docker Container Management
Exec=kitematic
-Terminal=false
Icon=kitematic
+Terminal=false
+Type=Application
Categories=System
diff --git a/kitematic.install b/kitematic.install
deleted file mode 100644
index 584c36993df1..000000000000
--- a/kitematic.install
+++ /dev/null
@@ -1,8 +0,0 @@
-post_install() {
- gtk-update-icon-cache -q -t -f /usr/share/icons/hicolor
- update-desktop-database -q
-}
-
-post_upgrade() {
- post_install $1
-}