summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSander Boom2015-09-18 19:53:18 +0200
committerSander Boom2015-09-18 19:53:18 +0200
commit942e2091ee86cdf2de39e5d38e1d3a8dea54df67 (patch)
treebc9070091983069e77adf69fedab42f6edf02981
downloadaur-942e2091ee86cdf2de39e5d38e1d3a8dea54df67.tar.gz
Initial commit
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD71
-rw-r--r--kitematic.desktop8
-rw-r--r--kitematic.install28
-rw-r--r--kitematic.svg8
5 files changed, 143 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c10b01c1e759
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = kitematic
+ pkgdesc = Visual Docker Container Management
+ pkgver = 0.7.2.r128.ge8e1fba
+ pkgrel = 1
+ url = https://kitematic.com/
+ install = kitematic.install
+ arch = x86_64
+ license = apache
+ makedepends = git
+ makedepends = npm
+ depends = docker
+ depends = nodejs
+ depends = desktop-file-utils
+ depends = libxtst
+ depends = alsa-lib
+ depends = libnotify
+ depends = gconf
+ depends = gtk2
+ provides = kitematic
+ source = git+https://github.com/zedtux/kitematic#branch=linux-support
+ source = kitematic.desktop
+ source = kitematic.svg
+ sha256sums = SKIP
+ sha256sums = 7d547df74ed4f0553bf77f28c90f13f9b62eefd75bfa1d4d23da0f1cd2d3ce51
+ sha256sums = 954d9803f49e475bc3242ad8b5dbfe5f3be9b532434ff260e1cf5c929f018617
+
+pkgname = kitematic
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7106da264bc5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,71 @@
+# Maintainer: Sander Boom <sanderboom@gmail.com>
+# Upstream URL Kitematic: https://github.com/kitematic/kitematic
+# Upstream URL linux-support: https://github.com/zedtux/kitematic
+
+# Kitematic support for linux is not yet official. This package aims to be a
+# quick-and-dirty solution to install and run (providing a *.desktop file) for
+# the time being.
+
+pkgname=kitematic
+pkgver=0.7.2.r128.ge8e1fba
+pkgrel=1
+pkgdesc="Visual Docker Container Management"
+arch=('x86_64')
+url="https://kitematic.com/"
+license=('apache')
+groups=()
+depends=(
+ 'docker'
+ 'nodejs'
+ 'desktop-file-utils'
+ 'libxtst'
+ 'alsa-lib'
+ 'libnotify'
+ 'gconf'
+ 'gtk2'
+)
+makedepends=('git' 'npm')
+provides=("${pkgname}")
+provides=("${pkgname}")
+backup=()
+options=()
+install="${pkgname}.install"
+source=(
+ "git+https://github.com/zedtux/${pkgname}#branch=linux-support"
+ "${pkgname}.desktop"
+ "${pkgname}.svg"
+)
+noextract=()
+sha256sums=(
+ 'SKIP'
+ '7d547df74ed4f0553bf77f28c90f13f9b62eefd75bfa1d4d23da0f1cd2d3ce51'
+ '954d9803f49e475bc3242ad8b5dbfe5f3be9b532434ff260e1cf5c929f018617'
+)
+
+pkgver() {
+ cd "$srcdir/${pkgname}"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/${pkgname}"
+ npm install electron-prebuilt@^0.27.3
+ npm install
+ ./node_modules/.bin/grunt release
+}
+
+package() {
+ cd "${srcdir}"
+
+ # Application
+ install -dm755 "${pkgdir}/opt"
+ cp -rp "${pkgname}/dist/linux/Kitematic-linux-x64/" "${pkgdir}/opt/"
+
+ # Exec
+ install -dm755 "${pkgdir}/usr/bin"
+ ln -sf "/opt/Kitematic-linux-x64/Kitematic" "${pkgdir}/usr/bin/${pkgname}"
+
+ # Desktop
+ install -Dm644 "${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ install -Dm644 "${pkgname}.svg" "${pkgdir}/usr/share/icons/hicolor/scalable/apps/${pkgname}.svg"
+}
diff --git a/kitematic.desktop b/kitematic.desktop
new file mode 100644
index 000000000000..f1c42394917a
--- /dev/null
+++ b/kitematic.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Type=Application
+Name=Kitematic
+Comment=Visual Docker Container Management
+Exec=kitematic
+Terminal=false
+Icon=kitematic
+Categories=Development
diff --git a/kitematic.install b/kitematic.install
new file mode 100644
index 000000000000..905b35595edf
--- /dev/null
+++ b/kitematic.install
@@ -0,0 +1,28 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f /usr/share/icons/hicolor
+ update-desktop-database -q
+
+ cat << _EOF
+
+ ==> Kitematic install/upgrade note:
+ ------------------------------------------------------------------------------
+ Linux support for Kitematic is not yet official.
+
+ This AUR package solely installs a binary build from the linux-support branch
+ at https://github.com/zedtux/kitematic and adds a .desktop file and icon.
+
+ For the rest you are on your own ;)
+ See:
+ - https://github.com/kitematic/kitematic/wiki/Early-Linux-Support
+ - https://github.com/kitematic/kitematic/issues/49
+
+_EOF
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}
diff --git a/kitematic.svg b/kitematic.svg
new file mode 100644
index 000000000000..9ffdb1e54024
--- /dev/null
+++ b/kitematic.svg
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8" standalone="no"?>
+<svg width="256px" height="256px" viewBox="0 0 256 256" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" preserveAspectRatio="xMinYMin meet">
+ <g>
+ <path d="M203.031173,255.890648 L128.095417,255.890648 C103.121498,255.890648 78.13358,256.13669 53.1606614,255.890648 C27.8077441,255.640604 5.5058168,237.389435 1.01583144,212.256071 C-0.594163313,203.243506 0.191834124,193.502815 0.191834124,184.394233 L0.191834124,82.0794674 C0.191834124,72.5438117 0.123834345,63.0051554 0.191834124,53.4694996 C0.350833605,31.2306381 13.9267893,10.9201114 35.0107206,3.22977608 C45.4596865,-0.581885766 56.341651,0.0372217351 67.2366155,0.0372217351 L114.513461,0.0372217351 C143.458367,0.0372217351 172.402273,-0.000784864328 201.347178,0.0372217351 C220.939114,0.0632262505 239.147055,9.46885943 249.029023,26.7318569 C255.633001,38.2698604 256,50.4139691 256,63.1711842 L256,162.133368 L256,199.274817 C256,216.548816 250.320019,232.626608 236.623063,243.875561 C227.200094,251.614905 215.223133,255.890648 203.031173,255.890648" fill="#3CB5E8"></path>
+ <path d="M46.365,63.143 L46.365,195.651 L82.694,195.651 L82.527,152.94 L99.352,132.536 L119.923,195.651 L158.868,195.651 L126.955,107.256 L158.951,62.975 L113.247,62.975 L82.527,99.22 L82.527,63.059 L46.365,63.143" fill="#FFFFFF"></path>
+ <path d="M215.119,63.059 L165.842,63.059 L194.27,106.196 L166.903,195.651 L215.119,195.651 L215.119,63.059" fill="#FFFFFF"></path>
+ </g>
+</svg> \ No newline at end of file