summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlessio Fachechi2016-09-22 20:23:24 +0200
committerAlessio Fachechi2016-09-22 20:23:24 +0200
commitc92feaacf2608566293955b4ab9c5a3498406350 (patch)
tree60efc16d8ac9c527970fd29b2193f878d553ec73
parent1406724b0d2a2c1d0878bd4c1d73a29ea625de5d (diff)
downloadaur-c92feaacf2608566293955b4ab9c5a3498406350.tar.gz
Updated to v0.12.0. Build from own Github repository.
-rw-r--r--PKGBUILD65
1 files changed, 28 insertions, 37 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1e7a82d2332d..61467b7cc8ea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,47 +1,38 @@
-# Maintainer: Sander Boom <sanderboom@gmail.com>
-# Improvements via PR welcome at: https://github.com/sanderboom/aur-kitematic
-#
-# Kitematic support for linux is still in Alpha. This package aims to be a
-# quick-and-dirty solution to install and run (providing a *.desktop file) for
-# the time being.
-#
-# Upstream URL Kitematic: https://github.com/kitematic/kitematic
+# Maintainer: Alessio Fachechi <alessio.fachechi@gmail.com>
pkgname=kitematic
-pkgver='0.9.3'
+pkgver=0.12.0
pkgrel=1
-pkgdesc="Visual Docker Container Management"
+pkgdesc='Visual Docker Container Management'
arch=('x86_64')
-url="https://kitematic.com/"
-license=('apache')
-depends=(
- 'docker'
- 'desktop-file-utils'
-)
-makedepends=('tar')
-provides=("${pkgname}")
-install="${pkgname}.install"
+url='https://github.com/docker/kitematic'
+license=('Apache')
+depends=('docker' 'nodejs')
+makedepends=('git' 'npm' 'nodejs-grunt-cli')
+conflicts=('kitematic')
source=(
- "https://raw.githubusercontent.com/sanderboom/kitematic/release/bin/Kitematic-linux-x64.tar.xz"
- "${pkgname}.desktop"
- "${pkgname}.svg"
+ "$pkgname::git+https://github.com/docker/kitematic.git"
+ "$pkgname.desktop"
+ "$pkgname.svg"
+)
+sha256sums=(
+ 'SKIP'
+ '448603660a205037c83125759e523cfec9cf1a93c0b1317482740a04292d5bdc'
+ '954d9803f49e475bc3242ad8b5dbfe5f3be9b532434ff260e1cf5c929f018617'
)
-sha256sums=('df3a4d59ae502143a717e81ccb405ec53cd3d5dea69d21ee204e9682dfe5cc37'
- '448603660a205037c83125759e523cfec9cf1a93c0b1317482740a04292d5bdc'
- '954d9803f49e475bc3242ad8b5dbfe5f3be9b532434ff260e1cf5c929f018617')
-
-package() {
- cd "${srcdir}"
- # Application
- install -dm755 "${pkgdir}/opt"
- tar xf Kitematic-linux-x64.tar.xz -C "${pkgdir}/opt"
+build() {
+ cd "$pkgname"
+ git checkout tags/v$pkgver -b $pkgver
+ npm install
+ grunt babel less copy:dev shell:linux_npm electron-packager:build
+}
- # Exec
- install -dm755 "${pkgdir}/usr/bin"
- ln -sf "/opt/Kitematic (Alpha)-linux-x64/Kitematic (Alpha)" "${pkgdir}/usr/bin/${pkgname}"
+package() {
+ install -dm755 "$pkgdir"/{opt,usr/bin}
+ install -Dm644 "$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
+ install -Dm644 "$pkgname.svg" "$pkgdir/usr/share/icons/hicolor/scalable/apps/$pkgname.svg"
- # Desktop
- install -Dm644 "${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
- install -Dm644 "${pkgname}.svg" "${pkgdir}/usr/share/icons/hicolor/scalable/apps/${pkgname}.svg"
+ cp -R "$pkgname/dist/Kitematic-linux-x64/" "$pkgdir/opt/$pkgname"
+ ln -s "/opt/$pkgname/Kitematic" "$pkgdir/usr/bin/kitematic"
}