summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVedant K2023-01-27 20:17:03 +0530
committerVedant K2023-01-27 20:17:03 +0530
commitbc0aaf4fa2ab1396b3b7cdc749cddfba0178eb05 (patch)
tree685a8b3e53a92f441f4468719ef96f2ee7f3b459
downloadaur-klotho.tar.gz
feat: upload package@v0.6.0
-rw-r--r--.SRCINFO11
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD16
3 files changed, 28 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..67721105d9a6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,11 @@
+pkgbase = klotho
+ pkgdesc = An Infrastructure from Code CLI tool that transforms plain code into cloud native code.
+ pkgver = 0.6.0
+ pkgrel = 1
+ url = https://klo.dev/
+ arch = any
+ license = APACHE
+ source = klotho_linux_amd64::https://github.com/klothoplatform/klotho/releases/download/v0.6.0/klotho_linux_amd64
+ sha256sums = 470a358e015b2f9d19643052f83a8aad76adde9b3b3fd04cdd76d7612ddf8520
+
+pkgname = klotho
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..fef2ea330d31
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+klotho*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6d77e44e4895
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,16 @@
+# Maintainer: Vedant K (gamemaker1) <gamemaker0042 at gmail dot com>
+
+pkgname=klotho
+pkgver=0.6.0
+pkgrel=1
+epoch=
+pkgdesc="An Infrastructure from Code CLI tool that transforms plain code into cloud native code."
+arch=("any")
+url="https://klo.dev/"
+license=("APACHE")
+source=("${pkgname}_linux_amd64::https://github.com/klothoplatform/klotho/releases/download/v${pkgver}/${pkgname}_linux_amd64")
+sha256sums=('470a358e015b2f9d19643052f83a8aad76adde9b3b3fd04cdd76d7612ddf8520')
+
+package() {
+ install -Dm775 "${srcdir}/${pkgname}_linux_amd64" "${pkgdir}/usr/bin/klotho"
+}