summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Bebbington2017-11-03 23:48:19 +0000
committerTom Bebbington2017-11-03 23:51:59 +0000
commit7e94e81a124411f7c30e4dd45343cc45b53270c6 (patch)
tree7c8b2d0f84878a63b7ef6d04410edde383fa3ddc
parent373fb1ab93dee11cb3ddb9d20dc84ffea031cba1 (diff)
downloadaur-7e94e81a124411f7c30e4dd45343cc45b53270c6.tar.gz
Now packages Kode Studio, forked from visual-studio-code
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD48
-rw-r--r--kode-studio.desktop10
-rw-r--r--visual-studio-code.desktop10
4 files changed, 40 insertions, 55 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 507bb74f3f4f..4468a457f999 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,10 @@
-# Generated by mksrcinfo v8
-# Tue Oct 17 21:05:13 UTC 2017
-pkgbase = visual-studio-code
- pkgdesc = Visual Studio Code: Editor for building and debugging modern web and cloud applications (official binary version)
- pkgver = 1.17.2
+pkgbase = kode-studio-bin
+ pkgdesc = Kode Studio is an IDE specifically tailored for Kha.
+ pkgver = 17.9.1
pkgrel = 1
- url = https://code.visualstudio.com/
+ url = http://kha.tech/download
arch = x86_64
- arch = i686
- license = custom: commercial
+ license = MIT
depends = fontconfig
depends = libxtst
depends = gtk2
@@ -21,14 +18,10 @@ pkgbase = visual-studio-code
depends = libxss
depends = gvfs
provides = vscode,visualstudiocode
- source_x86_64 = code_x64_1.17.2.tar.gz::https://vscode-update.azurewebsites.net/1.17.2/linux-x64/stable
- source_x86_64 = visual-studio-code.desktop
- sha256sums_x86_64 = b93e2a282fdae04f355aa6e76fc4c15fb3452f4bcb64019d508a3a8337e76778
- sha256sums_x86_64 = de88d95db3f55ce58ffd3c229cbde566099384d4f005cf887b00ccaeed605984
- source_i686 = code_ia32_1.17.2.tar.gz::https://vscode-update.azurewebsites.net/1.17.2/linux-ia32/stable
- source_i686 = visual-studio-code.desktop
- sha256sums_i686 = 028ac50b98141c072caf275363465073f9d3321ec410cc547bee4d7cc991b612
- sha256sums_i686 = de88d95db3f55ce58ffd3c229cbde566099384d4f005cf887b00ccaeed605984
+ source_x86_64 = https://github.com/Kode/KodeStudio/releases/download/v17.9.1/KodeStudio-linux64.tar.gz
+ source_x86_64 = kode-studio.desktop
+ sha256sums_x86_64 = a1ac4a5b9b74a8f5529ed616d6e4401599d1a33a4729eb1bdd7e5062a1b59cb0
+ sha256sums_x86_64 = 085056b38a51192641b9c7daac35515491c1202374369a9b1e19cdf764273c11
-pkgname = visual-studio-code
+pkgname = kode-studio-bin
diff --git a/PKGBUILD b/PKGBUILD
index 52c79889fd02..60d03e11a8fb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,32 @@
-# Maintainer: D. Can Celasun <can[at]dcc[dot]im>
+# Maintainer: Tom Bebbington <tombebb@protonmail.com>
-pkgname=visual-studio-code
-pkgver=1.17.2
+pkgname=kode-studio-bin
+_pkgname=kode-studio
+pkgver=17.9.1
pkgrel=1
-pkgdesc="Visual Studio Code: Editor for building and debugging modern web and cloud applications (official binary version)"
-arch=('x86_64' 'i686')
-url="https://code.visualstudio.com/"
-license=('custom: commercial')
+pkgdesc="Kode Studio is an IDE specifically tailored for Kha."
+arch=('x86_64')
+url="http://kha.tech/download"
+license=('MIT')
provides=('vscode','visualstudiocode')
depends=(fontconfig libxtst gtk2 python cairo alsa-lib gconf nss gcc-libs libnotify libxss gvfs)
-source_x86_64=(code_x64_${pkgver}.tar.gz::https://vscode-update.azurewebsites.net/${pkgver}/linux-x64/stable
- ${pkgname}.desktop
+source_x86_64=(https://github.com/Kode/KodeStudio/releases/download/v${pkgver}/KodeStudio-linux64.tar.gz
+ ${_pkgname}.desktop
)
-source_i686=(code_ia32_${pkgver}.tar.gz::https://vscode-update.azurewebsites.net/${pkgver}/linux-ia32/stable
- ${pkgname}.desktop
- )
-sha256sums_x86_64=('b93e2a282fdae04f355aa6e76fc4c15fb3452f4bcb64019d508a3a8337e76778'
- 'de88d95db3f55ce58ffd3c229cbde566099384d4f005cf887b00ccaeed605984')
-sha256sums_i686=('028ac50b98141c072caf275363465073f9d3321ec410cc547bee4d7cc991b612'
- 'de88d95db3f55ce58ffd3c229cbde566099384d4f005cf887b00ccaeed605984')
+sha256sums_x86_64=('a1ac4a5b9b74a8f5529ed616d6e4401599d1a33a4729eb1bdd7e5062a1b59cb0'
+ '085056b38a51192641b9c7daac35515491c1202374369a9b1e19cdf764273c11')
package() {
- _pkg=VSCode-linux-x64
- if [ "${CARCH}" = "i686" ]; then
- _pkg=VSCode-linux-ia32
- fi
-
- install -d "${pkgdir}/usr/share/licenses/${pkgname}"
- install -d "${pkgdir}/opt/${pkgname}"
+ install -d "${pkgdir}/usr/share/licenses/${_pkgname}"
+ install -d "${pkgdir}/opt/${_pkgname}"
install -d "${pkgdir}/usr/bin"
install -d "${pkgdir}/usr/share/applications"
install -d "${pkgdir}/usr/share/icons"
- install -m644 "${srcdir}/${_pkg}/resources/app/LICENSE.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- install -m644 "${srcdir}/${_pkg}/resources/app/resources/linux/code.png" "${pkgdir}/usr/share/icons/${pkgname}.png"
- install -m644 "${srcdir}/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ install -m644 "${srcdir}/resources/app/LICENSE.txt" "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+ install -m644 "${srcdir}/resources/app/resources/linux/code.png" "${pkgdir}/usr/share/icons/${_pkgname}.png"
+ install -m644 "${srcdir}/${_pkgname}.desktop" "${pkgdir}/usr/share/applications/${_pkgname}.desktop"
- cp -r "${srcdir}/${_pkg}/"* "${pkgdir}/opt/${pkgname}" -R
- ln -s /opt/${pkgname}/bin/code "${pkgdir}"/usr/bin/code
+ cp -r "${srcdir}/"* "${pkgdir}/opt/${_pkgname}" -R
+ ln -s /opt/${_pkgname}/bin/kodestudio "${pkgdir}"/usr/bin/kodestudio
+ ln -s /opt/${_pkgname}/bin/kodestudio "${pkgdir}"/usr/bin/${_pkgname}
}
diff --git a/kode-studio.desktop b/kode-studio.desktop
new file mode 100644
index 000000000000..e767b971560f
--- /dev/null
+++ b/kode-studio.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Exec=/usr/bin/kodestudio %f
+Icon=visual-studio-code
+Terminal=false
+Type=Application
+Name=Kode Studio
+Comment=Kode Studio is an IDE specifically tailored for Kha.
+Categories=Development;IDE;Utility;TextEditor;
+StartupNotify=true
+StartupWMClass=code
diff --git a/visual-studio-code.desktop b/visual-studio-code.desktop
deleted file mode 100644
index 055059d4b25f..000000000000
--- a/visual-studio-code.desktop
+++ /dev/null
@@ -1,10 +0,0 @@
-[Desktop Entry]
-Exec=/usr/bin/code %f
-Icon=visual-studio-code
-Terminal=false
-Type=Application
-Name=Visual Studio Code
-Comment=Editor for building and debugging modern web and cloud applications
-Categories=Development;WebDevelopment;IDE;Utility;TextEditor;
-StartupNotify=true
-StartupWMClass=code