summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorD. Can Celasun2016-09-09 11:39:18 +0200
committerD. Can Celasun2016-09-09 11:39:18 +0200
commiteadfc95a2d79777ffa9a7ecd30be3c4a33b338ce (patch)
tree2811b9eb8f4393337da3cc3718e9736c85d853ff
parent6671b2b135f6b582e0bb1b0a98a1c153e56d195a (diff)
downloadaur-eadfc95a2d79777ffa9a7ecd30be3c4a33b338ce.tar.gz
Update to 1.5.1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD17
2 files changed, 13 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d9e8679d4475..85b4bb481026 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Thu Sep 8 19:31:36 UTC 2016
+# Fri Sep 9 09:39:04 UTC 2016
pkgbase = visual-studio-code
pkgdesc = Editor for building and debugging modern web and cloud applications
- pkgver = 1.5.0
+ pkgver = 1.5.1
pkgrel = 1
url = https://code.visualstudio.com/
arch = x86_64
@@ -19,13 +19,13 @@ pkgbase = visual-studio-code
depends = gcc-libs
depends = libnotify
provides = vscode,visualstudiocode
- source_x86_64 = vscode64_1.5.0.zip::https://az764295.vo.msecnd.net/stable/4fc690be310dd02e0ab6529c0b9bf348a8b26a19/code-stable-code_1.5.0-1473324851_amd64.tar.gz
+ source_x86_64 = vscode64_1.5.1.zip::https://az764295.vo.msecnd.net/stable/07d663dc1bd848161edf4cd4ce30cce410d3d877/code-stable-code_1.5.1-1473370243_amd64.tar.gz
source_x86_64 = visual-studio-code.desktop
- md5sums_x86_64 = 7b4de90d6a51f907603877cac9432cda
+ md5sums_x86_64 = cf4cc29ef7e70b5fc7e226b08b039a37
md5sums_x86_64 = 89eb024d17221e5c92c99c390eaf92ce
- source_i686 = vscode32_1.5.0.zip::https://az764295.vo.msecnd.net/stable/4fc690be310dd02e0ab6529c0b9bf348a8b26a19/code-stable-code_1.5.0-1473325631_i386.tar.gz
+ source_i686 = vscode32_1.5.1.zip::https://az764295.vo.msecnd.net/stable/07d663dc1bd848161edf4cd4ce30cce410d3d877/code-stable-code_1.5.1-1473369468_i386.tar.gz
source_i686 = visual-studio-code.desktop
- md5sums_i686 = 2270dbd72ff7caa274ae9c291ba83960
+ md5sums_i686 = ea7f1eceb1e3d5f50ce10a92e492f86a
md5sums_i686 = 89eb024d17221e5c92c99c390eaf92ce
pkgname = visual-studio-code
diff --git a/PKGBUILD b/PKGBUILD
index 1ceaee03c034..606c22be3dea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: D. Can Celasun <dcelasun[at]gmail[dot]com>
pkgname=visual-studio-code
-pkgver=1.5.0
+pkgver=1.5.1
pkgrel=1
pkgdesc="Editor for building and debugging modern web and cloud applications"
arch=('x86_64' 'i686')
@@ -9,18 +9,18 @@ url="https://code.visualstudio.com/"
license=('custom: commercial')
provides=('vscode','visualstudiocode')
depends=(fontconfig libxtst gtk2 python cairo alsa-lib gconf nss gcc-libs libnotify)
-_release=4fc690be310dd02e0ab6529c0b9bf348a8b26a19
-_ts64=1473324851
-_ts32=1473325631
+_release=07d663dc1bd848161edf4cd4ce30cce410d3d877
+_ts64=1473370243
+_ts32=1473369468
source_x86_64=(vscode64_${pkgver}.zip::https://az764295.vo.msecnd.net/stable/$_release/code-stable-code_${pkgver}-${_ts64}_amd64.tar.gz
${pkgname}.desktop
)
source_i686=(vscode32_${pkgver}.zip::https://az764295.vo.msecnd.net/stable/$_release/code-stable-code_${pkgver}-${_ts32}_i386.tar.gz
${pkgname}.desktop
)
-md5sums_x86_64=('7b4de90d6a51f907603877cac9432cda'
+md5sums_x86_64=('cf4cc29ef7e70b5fc7e226b08b039a37'
'89eb024d17221e5c92c99c390eaf92ce')
-md5sums_i686=('2270dbd72ff7caa274ae9c291ba83960'
+md5sums_i686=('ea7f1eceb1e3d5f50ce10a92e492f86a'
'89eb024d17221e5c92c99c390eaf92ce')
package() {
_pkg=VSCode-linux-x64
@@ -33,14 +33,11 @@ package() {
install -d "${pkgdir}/usr/bin"
install -d "${pkgdir}/usr/share/applications"
install -d "${pkgdir}/usr/share/icons"
-
+
install -m644 "${srcdir}/${_pkg}/resources/app/LICENSE.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
install -m644 "${srcdir}/${_pkg}/resources/app/resources/linux/code.png" "${pkgdir}/usr/share/icons/${pkgname}.png"
install -m644 "${srcdir}/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
- rm -f "${srcdir}"/${pkgname}.desktop
- rm -f "${srcdir}"/${_pkg}.zip
-
cp -r "${srcdir}/${_pkg}/"* "${pkgdir}/opt/${pkgname}" -R
ln -s /opt/${pkgname}/bin/code "${pkgdir}"/usr/bin/code
}