summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKonstantin Nikiforov2019-04-11 10:45:48 +0300
committerKonstantin Nikiforov2019-04-11 10:45:48 +0300
commit1d5641e4317548913c55fa27de9b8459b4e9af36 (patch)
treed6df7e52bf8155c5442af8e86945216a85d72706
downloadaur-kompose-git.tar.gz
It works!
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD31
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fbe64a3cb026
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = kompose-git
+ pkgdesc = kompose takes a Docker Compose file and translates it into Kubernetes resources (git version).
+ pkgver = r1220.fb7a92ca
+ pkgrel = 1
+ url = https://github.com/kubernetes/kompose
+ arch = i686
+ arch = x86_64
+ arch = aarch64
+ arch = armv7h
+ arch = armv6h
+ arch = arm
+ license = apache
+ makedepends = git
+ makedepends = go
+ provides = kompose
+ conflicts = kompose
+ conflicts = kompose-bin
+ source = kompose-git::git+https://github.com/kubernetes/kompose
+ sha256sums = SKIP
+
+pkgname = kompose-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5f98b6cbec1c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+pkgname=kompose-git
+__gitroot=github.com/kubernetes/kompose
+pkgver=r1220.fb7a92ca
+pkgrel=1
+pkgdesc="kompose takes a Docker Compose file and translates it into Kubernetes resources (git version)."
+arch=('i686' 'x86_64' 'aarch64' 'armv7h' 'armv6h' 'arm')
+url="https://${__gitroot}"
+license=('apache')
+depends=( )
+makedepends=('git' 'go')
+provides=('kompose')
+conflicts=('kompose' 'kompose-bin')
+_gourl=$__gitroot
+source=("$pkgname::git+https://${__gitroot}")
+sha256sums=('SKIP')
+
+build() {
+ GOPATH="$srcdir" go get -v -x ${_gourl}
+}
+
+package() {
+ mkdir -p "$pkgdir/usr/bin"
+ install -p -m755 "$srcdir/bin/"* "$pkgdir/usr/bin"
+}
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+# vim:set ts=2 sw=2 et: