summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStanislav Seletskiy2017-08-08 00:21:39 +0700
committerStanislav Seletskiy2017-08-08 00:21:39 +0700
commitc9e6959f3fa3716aa4c9ad83c23e3e47d146f47f (patch)
treee5b1882629ae11af5ca9f90c67dea801766c144c
parent4ed40c487a9e854749d0edf80c48701fd6ffc5c7 (diff)
downloadaur-konsole-cursor.tar.gz
use git as base
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD16
2 files changed, 12 insertions, 5 deletions
diff --git a/.gitignore b/.gitignore
index 7caf235b600e..46c29817c1a3 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,3 +1,4 @@
*.tar.xz
src/
pkg/
+konsole/
diff --git a/PKGBUILD b/PKGBUILD
index efcc6de5e9ea..5cb9645295b2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=konsole-cursor
_pkgname=konsole
-pkgver=17.04.3
+pkgver=r6136.8d27a2d3
pkgrel=1
arch=('i686' 'x86_64')
url='http://kde.org/applications/system/konsole/'
@@ -16,20 +16,26 @@ makedepends=('extra-cmake-modules' 'kdoctools' 'python')
optdepends=('kdebase-keditbookmarks: to manage bookmarks')
replaces=('kdebase-konsole' 'konsole')
conflicts=('kdebase-konsole<4.14.3-2' 'konsole')
-source=("http://download.kde.org/stable/applications/${pkgver}/src/konsole-${pkgver}.tar.xz"
+
+source=('git://anongit.kde.org/konsole.git'
"0001-remove-cursor-height-padding-from-top.patch")
-sha1sums=('a9a99d46d17f5b49f35e84a9e5cb682658c10716'
+sha1sums=('SKIP'
'f4c8e0d88c89c43b2863ced4399e6af9683271b5')
+pkgver() {
+ cd konsole
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
prepare() {
mkdir -p build
- cd ${srcdir}/$_pkgname-$pkgver
+ cd ${srcdir}/konsole
patch -Np1 -i ${srcdir}/0001-remove-cursor-height-padding-from-top.patch
}
build() {
cd build
- cmake ../$_pkgname-$pkgver \
+ cmake ../konsole \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
-DKDE_INSTALL_LIBDIR=lib \