summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordanitool2015-09-13 12:10:02 +0200
committerdanitool2015-09-13 12:10:02 +0200
commit08d11299d1a0e3c88c34c47729e977f9d23866e2 (patch)
treea7a6bfcdb258fa6f26342545fa5690bbc92274d0
downloadaur-konversation-legacy.tar.gz
Initial import
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD51
-rw-r--r--konversation.install12
-rw-r--r--use-qdbus-qt4.patch174
4 files changed, 268 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a2de5c496851
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+# Generated by makepkg 4.2.1
+# Sun Sep 13 10:08:31 UTC 2015
+pkgbase = konversation-legacy
+ pkgdesc = A user friendly IRC client for KDE
+ pkgver = 1.5.1
+ pkgrel = 1
+ url = http://konversation.kde.org
+ install = konversation.install
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ license = FDL
+ makedepends = automoc4
+ makedepends = cmake
+ makedepends = pkgconfig
+ makedepends = docbook-xml
+ makedepends = optipng
+ depends = kdebase-runtime
+ depends = kdepimlibs
+ optdepends = python: python scripting support
+ optdepends = kdebase-konsole: open a terminal in konversation
+ optdepends = qca-ossl: Diffie-Hellman key exchange and Blowfish ECB/CBC support
+ conflicts = konversation
+ conflicts = konversation-git
+ source = http://download.kde.org/download.php?url=stable/konversation/1.5.1/src/konversation-1.5.1.tar.xz
+ source = use-qdbus-qt4.patch
+ sha1sums = 1b69db93d2c0a38b631dd92065fa6e7490ffbfbe
+ sha1sums = a21aed6079de7693e67abe13798807920de01f6a
+
+pkgname = konversation-legacy
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..88a5a75f405b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# $Id$
+# Maintainer: Tom Gundersen <teg@jklm.no>
+# Contributor: Stéphane Gaudreault <stephane@archlinux.org>
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
+# Contributor: James Rayner <iphitus@gmail.com>
+# Contributor: Sergio Jovani Guzman <moret@paretux.org>
+
+pkgname=konversation-legacy
+pkgver=1.5.1
+pkgrel=1
+pkgdesc="A user friendly IRC client for KDE"
+arch=('i686' 'x86_64')
+url="http://konversation.kde.org"
+depends=('kdebase-runtime' 'kdepimlibs')
+makedepends=('automoc4' 'cmake' 'pkgconfig' 'docbook-xml' 'optipng')
+optdepends=('python: python scripting support'
+ 'kdebase-konsole: open a terminal in konversation'
+ 'qca-ossl: Diffie-Hellman key exchange and Blowfish ECB/CBC support')
+conflicts=('konversation' 'konversation-git')
+license=('GPL2' 'FDL')
+install=konversation.install
+source=("http://download.kde.org/download.php?url=stable/konversation/${pkgver}/src/konversation-${pkgver}.tar.xz"
+ 'use-qdbus-qt4.patch')
+sha1sums=('1b69db93d2c0a38b631dd92065fa6e7490ffbfbe'
+ 'a21aed6079de7693e67abe13798807920de01f6a')
+
+prepare() {
+ mkdir build
+
+ cd konversation-${pkgver}
+ patch -p1 -i "${srcdir}"/use-qdbus-qt4.patch
+}
+
+build() {
+ cd build
+ cmake ../konversation-${pkgver} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_SKIP_RPATH=ON \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="${pkgdir}" install
+
+ # Remove a bunch of symlinks pointing to non-existant files
+ for _lang in pt_BR uk sv et de en nl it fr es ca; do
+ rm -f "${pkgdir}"/usr/share/doc/kde/html/${_lang}/konversation/common
+ done
+}
diff --git a/konversation.install b/konversation.install
new file mode 100644
index 000000000000..8834e059aa09
--- /dev/null
+++ b/konversation.install
@@ -0,0 +1,12 @@
+post_install() {
+ xdg-icon-resource forceupdate --theme hicolor &> /dev/null
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
diff --git a/use-qdbus-qt4.patch b/use-qdbus-qt4.patch
new file mode 100644
index 000000000000..800ab839bf5a
--- /dev/null
+++ b/use-qdbus-qt4.patch
@@ -0,0 +1,174 @@
+--- konversation-1.5/data/scripts/sayclip~ 2014-04-24 14:41:03.332179998 +0000
++++ konversation-1.5/data/scripts/sayclip 2014-04-24 14:41:24.752057066 +0000
+@@ -35,7 +35,7 @@
+ sys.exit("This script is intended to be run from within Konversation.")
+
+ try:
+- clipboard = subprocess.check_output(('qdbus', 'org.kde.klipper', '/klipper', 'getClipboardContents'))
++ clipboard = subprocess.check_output(('qdbus-qt4', 'org.kde.klipper', '/klipper', 'getClipboardContents'))
+ except subprocess.CalledProcessError:
+ konversation.dbus.error(i18n("Unable to retrieve clipboard contents from Klipper."), exit=True)
+
+--- konversation-1.5/data/scripts/uptime~ 2014-04-24 14:41:33.182008693 +0000
++++ konversation-1.5/data/scripts/uptime 2014-04-24 14:42:06.111819793 +0000
+@@ -19,7 +19,7 @@
+ } else {
+ $UPTIME = `cat /proc/uptime`;
+ if (not $UPTIME) {
+- exec 'qdbus', 'org.kde.konversation', '/irc', 'info', 'Could not read uptime. Check that /proc/uptime exists.';
++ exec 'qdbus-qt4', 'org.kde.konversation', '/irc', 'info', 'Could not read uptime. Check that /proc/uptime exists.';
+ }
+ @uparray = split(/\./, $UPTIME);
+ $seconds = $uparray[0];
+@@ -40,15 +40,15 @@
+ $minutes = int($seconds/60);
+ }
+ if( $days && $hours ) {
+- exec 'qdbus', 'org.kde.konversation', '/irc', 'say', $SERVER, $TARGET, "Uptime: $days days, $hours hours and $minutes minutes";
++ exec 'qdbus-qt4', 'org.kde.konversation', '/irc', 'say', $SERVER, $TARGET, "Uptime: $days days, $hours hours and $minutes minutes";
+ }
+ elsif( !$days && $hours ) {
+- exec 'qdbus', 'org.kde.konversation', '/irc', 'say', $SERVER, $TARGET, "Uptime: $hours hours and $minutes minutes";
++ exec 'qdbus-qt4', 'org.kde.konversation', '/irc', 'say', $SERVER, $TARGET, "Uptime: $hours hours and $minutes minutes";
+ }
+ elsif( $days && !$hours ) {
+- exec 'qdbus', 'org.kde.konversation', '/irc', 'say', $SERVER, $TARGET, "Uptime: $days days and $minutes minutes";
++ exec 'qdbus-qt4', 'org.kde.konversation', '/irc', 'say', $SERVER, $TARGET, "Uptime: $days days and $minutes minutes";
+ }
+ elsif( !$days && !$hours ) {
+- exec 'qdbus', 'org.kde.konversation', '/irc', 'say', $SERVER, $TARGET, "Uptime: $minutes minutes";
++ exec 'qdbus-qt4', 'org.kde.konversation', '/irc', 'say', $SERVER, $TARGET, "Uptime: $minutes minutes";
+ }
+
+--- konversation-1.5/data/scripts/mail~ 2014-04-24 14:42:12.458450062 +0000
++++ konversation-1.5/data/scripts/mail 2014-04-24 14:43:15.954752752 +0000
+@@ -18,18 +18,18 @@
+ getmails()
+ {
+
+- qdbus org.kde.kmail > /dev/null || {
+- qdbus org.kde.konversation /irc info "Sorry kmail is not running"
++ qdbus-qt4 org.kde.kmail > /dev/null || {
++ qdbus-qt4 org.kde.konversation /irc info "Sorry kmail is not running"
+ exit
+ }
+
+- for f in $(qdbus org.kde.kmail /KMail folderList) ; do
+- qdbus org.kde.kmail /KMail getFolder $f > /dev/null
+- MAILFOLDER=$(qdbus org.kde.kmail /Folder "displayPath" | grep -i $FOLDER)
++ for f in $(qdbus-qt4 org.kde.kmail /KMail folderList) ; do
++ qdbus-qt4 org.kde.kmail /KMail getFolder $f > /dev/null
++ MAILFOLDER=$(qdbus-qt4 org.kde.kmail /Folder "displayPath" | grep -i $FOLDER)
+ if [ "$MAILFOLDER" != "" ] ; then
+ FOUNDFOLDER=1
+- MAILCOUNT=$(qdbus org.kde.kmail /Folder unreadMessages )
+- MAILTOTALCOUNT=$(qdbus org.kde.kmail /Folder messages )
++ MAILCOUNT=$(qdbus-qt4 org.kde.kmail /Folder unreadMessages )
++ MAILTOTALCOUNT=$(qdbus-qt4 org.kde.kmail /Folder messages )
+ MAILTOTALCOUNT=$(($MAILCOUNT + $MAILTOTALCOUNT))
+ if [[ -z "$MAILCOUNT" ]] ; then MAILCOUNT = "0" ; fi
+ if [ "$MAILCOUNT" != 0 ] ; then
+@@ -41,7 +41,7 @@
+
+ if [[ -z "$FOUNDEMAIL" ]] ; then
+ if [[ -z "$FOUNDFOLDER" ]] ; then
+- qdbus org.kde.konversation /irc info "No email folders were found that had a name containing '$FOLDER'"
++ qdbus-qt4 org.kde.konversation /irc info "No email folders were found that had a name containing '$FOLDER'"
+ exit
+ else
+ echo "No new emails in any folders matching '$FOLDER'"
+@@ -66,5 +66,5 @@
+ # exit
+ #fi
+
+-getmails | head -n 3 | while read line; do qdbus org.kde.konversation /irc say $SERVER "$TARGET" "$line"; done
++getmails | head -n 3 | while read line; do qdbus-qt4 org.kde.konversation /irc say $SERVER "$TARGET" "$line"; done
+
+--- konversation-1.5/data/scripts/media~ 2014-04-24 14:43:22.754713792 +0000
++++ konversation-1.5/data/scripts/media 2014-04-24 14:43:30.764667903 +0000
+@@ -76,7 +76,7 @@
+ # 'qdbus' command installed by Qt. If you need to you can change this here,
+ # but beware that the output format of the alternate command has to match that
+ # of 'qdbus'.
+-dbus_command = 'qdbus'
++dbus_command = 'qdbus-qt4'
+
+ # If one of the title, album or artist metadata fields contains a character
+ # listed in FIXUP_CHARS, or if a string matching the regular expression given
+--- konversation-1.5/data/scripts/fortune~ 2014-04-24 14:43:37.497962666 +0000
++++ konversation-1.5/data/scripts/fortune 2014-04-24 14:43:45.934581009 +0000
+@@ -49,4 +49,4 @@
+ }
+ }
+ close(FORTUNES);
+-exec 'qdbus', 'org.kde.konversation', '/irc', 'say', $SERVER, $TARGET, $MESSAGE;
++exec 'qdbus-qt4', 'org.kde.konversation', '/irc', 'say', $SERVER, $TARGET, $MESSAGE;
+--- konversation-1.5/data/scripts/tinyurl~ 2014-04-24 14:43:50.867886087 +0000
++++ konversation-1.5/data/scripts/tinyurl 2014-04-24 14:44:22.844369658 +0000
+@@ -15,16 +15,16 @@
+ else
+ TINYURL="$(wget -T10 -t2 -qO- http://tinyurl.com/api-create.php?url=$URL|tail -1)"
+ fi
+-else qdbus org.kde.konversation /irc error "No url given: usage is \"/tinyurl URL [NickName]\""
++else qdbus-qt4 org.kde.konversation /irc error "No url given: usage is \"/tinyurl URL [NickName]\""
+ exit 1
+ fi
+
+ if test -z $TINYURL; then
+- qdbus org.kde.konversation /irc error "Unable run tinyurl script, please make sure you have curl or wget installed"
++ qdbus-qt4 org.kde.konversation /irc error "Unable run tinyurl script, please make sure you have curl or wget installed"
+ else
+ if test ! -z $NICK; then
+- qdbus org.kde.konversation /irc say $SERVER "$TARGET" "${NICK}: $TINYURL"
++ qdbus-qt4 org.kde.konversation /irc say $SERVER "$TARGET" "${NICK}: $TINYURL"
+ else
+- qdbus org.kde.konversation /irc say $SERVER "$TARGET" "$TINYURL"
++ qdbus-qt4 org.kde.konversation /irc say $SERVER "$TARGET" "$TINYURL"
+ fi
+ fi
+--- konversation-1.5/data/scripts/gauge~ 2014-04-24 14:44:32.460981276 +0000
++++ konversation-1.5/data/scripts/gauge 2014-04-24 14:45:00.634153375 +0000
+@@ -10,23 +10,23 @@
+
+ if [ ! $TARGET ]
+ then
+- qdbus org.kde.konversation /irc error "Can't write into status view."
++ qdbus-qt4 org.kde.konversation /irc error "Can't write into status view."
+ else
+ if [ ! $PERCENTAGE ]
+ then
+- qdbus org.kde.konversation /irc error "USAGE: $0 <percentage>"
++ qdbus-qt4 org.kde.konversation /irc error "USAGE: $0 <percentage>"
+ else
+ PERCENTAGE=`echo $PERCENTAGE | sed 's/^0\+//'`
+ LEFT=$(($PERCENTAGE/5))
+ RIGHT=$((20-$LEFT))
+
+ if [[ $PERCENTAGE -lt 0 ]]; then
+- qdbus org.kde.konversation /irc error "Percentage has to be bigger than 0"
++ qdbus-qt4 org.kde.konversation /irc error "Percentage has to be bigger than 0"
+ exit
+ fi
+
+ if [[ $PERCENTAGE -gt 100 ]]; then
+- qdbus org.kde.konversation /irc error "Percentage has to be smaller than 100"
++ qdbus-qt4 org.kde.konversation /irc error "Percentage has to be smaller than 100"
+ exit
+ fi
+
+@@ -64,6 +64,6 @@
+ OUTPUT="$OUTPUT *ding*"
+ fi
+
+- qdbus org.kde.konversation /irc say $SERVER "$TARGET" "Beer load $OUTPUT"
++ qdbus-qt4 org.kde.konversation /irc say $SERVER "$TARGET" "Beer load $OUTPUT"
+ fi
+ fi
+--- konversation-1.5/data/scripting_support/python/konversation/dbus.py~ 2014-04-24 14:48:10.343069193 +0000
++++ konversation-1.5/data/scripting_support/python/konversation/dbus.py 2014-04-24 14:45:29.863986156 +0000
+@@ -98,4 +98,4 @@
+
+ default_message_prefix = ''
+
+-_dbus_command = ('qdbus', 'org.kde.konversation', '/irc')
++_dbus_command = ('qdbus-qt4', 'org.kde.konversation', '/irc')