summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Cheng2021-04-16 03:53:00 -0400
committerEric Cheng2021-04-16 03:53:00 -0400
commit8d72bacd253bf71515b917bb3b0c73fc8ed551fa (patch)
tree14873d16971351db557891517a626119d8b647e5
parente5e823abe2fdf008f233869ad32a872e0a291ad3 (diff)
downloadaur-8d72bacd253bf71515b917bb3b0c73fc8ed551fa.tar.gz
better naming logic
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
2 files changed, 4 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d86ec5873eff..ef9c1671d19f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = kopia-bin
pkgdesc = A cross-platform backup-tool with encryption, deduplication, compression and cloud support.
pkgver = 0.8.1
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/kopia/kopia/
arch = x86_64
arch = aarch64
diff --git a/PKGBUILD b/PKGBUILD
index 8eeedab98619..54247da0ec9d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,11 @@
# Maintainer: Eric Cheng <ericcheng@hey.com>
pkgname=kopia-bin
-_pkgname=kopia
pkgdesc='A cross-platform backup-tool with encryption, deduplication, compression and cloud support.'
pkgver=0.8.1
# Uncomment for releases with hyphens
# _pkgver=$(echo "$pkgver" | tr '~' -)
-pkgrel=2
+pkgrel=3
arch=('x86_64' 'aarch64' 'armv7h')
url='https://github.com/kopia/kopia/'
license=('APACHE')
@@ -21,6 +20,6 @@ sha256sums_armv7h=('9006c5b48beb3ef935f79186ee6190905a1986838948f28fac0f1aed9c22
package() {
tar -xf data.tar.gz -C "$pkgdir"
- "$pkgdir/usr/bin/${_pkgname}" --completion-script-bash | install -Dm 644 /dev/stdin "$pkgdir/usr/share/bash-completion/completions/${pkgname%-bin}"
- "$pkgdir/usr/bin/${_pkgname}" --completion-script-zsh | install -Dm 644 /dev/stdin "$pkgdir/usr/share/zsh/site-functions/_${pkgname%-bin}"
+ "$pkgdir/usr/bin/${pkgname%-bin}" --completion-script-bash | install -Dm 644 /dev/stdin "$pkgdir/usr/share/bash-completion/completions/${pkgname%-bin}"
+ "$pkgdir/usr/bin/${pkgname%-bin}" --completion-script-zsh | install -Dm 644 /dev/stdin "$pkgdir/usr/share/zsh/site-functions/_${pkgname%-bin}"
}