summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDennis Oehme2018-07-31 09:04:57 +0200
committerDennis Oehme2018-07-31 09:04:57 +0200
commit34c2ba1ab80bfc788a2f4104b3b931181003238d (patch)
treeb03fd8035c7c6eb1ee611e285218c502a85e1eb0
parentf6675a522f3407bce8b9bfccf91058eb983ab3d3 (diff)
downloadaur-34c2ba1ab80bfc788a2f4104b3b931181003238d.tar.gz
fixed checksum issue for cached files
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD6
3 files changed, 6 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4907070ff79d..a0745315a938 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,11 @@
pkgbase = kops-bin
pkgdesc = Kubernetes Operations (kops) - Production Grade K8s Installation, Upgrades, and Management
pkgver = 1.9.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/kubernetes/kops
arch = x86_64
license = apache
- source_x86_64 = https://github.com/kubernetes/kops/releases/download/1.9.2/kops-linux-amd64
+ source_x86_64 = kops-bin-1.9.2::https://github.com/kubernetes/kops/releases/download/1.9.2/kops-linux-amd64
md5sums_x86_64 = 0222c5e734a8fa625445d65b7a5f60e5
pkgname = kops-bin
diff --git a/.gitignore b/.gitignore
index a251571e53ac..e305b4e3d112 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,5 @@
*.tar.*
src/
pkg/
+kops-bin-*
kops-linux-*
diff --git a/PKGBUILD b/PKGBUILD
index 2352494866d4..63dccaf3b9fc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,17 +3,17 @@
pkgname=kops-bin
pkgver=1.9.2
_build=${pkgver}
-pkgrel=1
+pkgrel=2
pkgdesc='Kubernetes Operations (kops) - Production Grade K8s Installation, Upgrades, and Management'
url='https://github.com/kubernetes/kops'
arch=('x86_64')
license=('apache')
conflicts=()
-source_x86_64=("https://github.com/kubernetes/kops/releases/download/${_build}/kops-linux-amd64")
+source_x86_64=("$pkgname-$pkgver::https://github.com/kubernetes/kops/releases/download/${_build}/kops-linux-amd64")
md5sums_x86_64=('0222c5e734a8fa625445d65b7a5f60e5')
package() {
install -d ${pkgdir}/usr/bin
- install -Dm755 ${srcdir}/kops-linux-amd64 ${pkgdir}/usr/bin/kops
+ install -Dm755 ${srcdir}/$pkgname-$pkgver ${pkgdir}/usr/bin/kops
}