summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorD3SOX2021-01-03 17:41:47 +0100
committerD3SOX2021-01-03 17:41:47 +0100
commit1b0a93091746667952b734ab602e03e1131456c7 (patch)
treedcb7aea98f1cb5cb9e869cc76c0234062064661f
downloadaur-1b0a93091746667952b734ab602e03e1131456c7.tar.gz
initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD59
-rw-r--r--kora-icon-theme.install16
3 files changed, 95 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..521dfb146671
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = kora-icon-theme
+ pkgdesc = SVG icon theme suitable for every desktop environment (dark and light versions, HiDPI support)
+ pkgver = 1.3.4
+ pkgrel = 1
+ url = https://github.com/bikass/kora
+ install = kora-icon-theme.install
+ arch = any
+ license = GPL3
+ depends = gtk-update-icon-cache
+ optdepends = hicolor-icon-theme: fallback Freedesktop.org Hicolor icon theme
+ optdepends = breeze-icons: fallback Breeze icon theme for Plasma Desktop
+ optdepends = gnome-icon-theme: fallback Gnome icon theme for Gnome Desktop
+ provides = kora-icon-theme
+ conflicts = kora-icon-theme
+ conflicts = korla-icon-theme
+ replaces = korla-icon-theme
+ source = https://github.com/bikass/kora/archive/v1.3.4.tar.gz
+ sha256sums = 34b7a069033b4dff5fccaad46a1d7538a5182259fed91a6f04395f64abab843c
+
+pkgname = kora-icon-theme
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ef6afb2829f0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,59 @@
+# Maintainer: Nico <d3sox at protonmail dot com>
+
+pkgname=kora-icon-theme
+pkgver=1.3.4
+pkgrel=1
+pkgdesc="SVG icon theme suitable for every desktop environment (dark and light versions, HiDPI support)"
+arch=("any")
+url="https://github.com/bikass/kora"
+license=("GPL3")
+depends=("gtk-update-icon-cache")
+provides=("kora-icon-theme")
+conflicts=("kora-icon-theme" "korla-icon-theme")
+replaces=("korla-icon-theme")
+optdepends=(
+ "hicolor-icon-theme: fallback Freedesktop.org Hicolor icon theme"
+ "breeze-icons: fallback Breeze icon theme for Plasma Desktop"
+ "gnome-icon-theme: fallback Gnome icon theme for Gnome Desktop")
+install="$pkgname.install"
+source=("https://github.com/bikass/kora/archive/v$pkgver.tar.gz")
+sha256sums=("34b7a069033b4dff5fccaad46a1d7538a5182259fed91a6f04395f64abab843c")
+
+_iconpath=usr/share/icons
+_iconcache=icon-theme.cache
+_iconnewcachescript=create-new-icon-theme.cache.sh
+
+package() {
+ cd "$srcdir/kora-$pkgver"
+
+ # Delete useless files from source folder
+ rm -f "kora/$_iconnewcachescript"
+ rm -f "kora/$_iconcache"
+ rm -f "kora-light/$_iconnewcachescript"
+ rm -f "kora-light/$_iconcache"
+ rm -f "kora-light-panel/$_iconnewcachescript"
+ rm -f "kora-light-panel/$_iconcache"
+ rm -f "kora-pgrey/$_iconnewcachescript"
+ rm -f "kora-pgrey/$_iconcache"
+
+ install -dm755 "$pkgdir/$_iconpath"
+ install -dm755 "$pkgdir/usr/share/licenses/$pkgname"
+
+ # The following --no-preserve=mode option is necessary since the creator works with
+ # the theme locally and he messed with modes in the past making some icons unreadable
+ # and some directories not executable if installed system wide while he didn't notice
+ # any issue because he installed the theme under the local icon folder on his system.
+ cp -dr --no-preserve=mode "kora" "$pkgdir/$_iconpath/kora"
+ cp -dr --no-preserve=mode "kora-light" "$pkgdir/$_iconpath/kora-light"
+ cp -dr --no-preserve=mode "kora-light-panel" "$pkgdir/$_iconpath/kora-light-panel"
+ cp -dr --no-preserve=mode "kora-pgrey" "$pkgdir/$_iconpath/kora-pgrey"
+
+ # Create empty icon cache files, they will be filled during post_install and
+ # post_upgrade scripts
+ touch -a "$pkgdir/$_iconpath/kora/$_iconcache"
+ touch -a "$pkgdir/$_iconpath/kora-light/$_iconcache"
+ touch -a "$pkgdir/$_iconpath/kora-light-panel/$_iconcache"
+ touch -a "$pkgdir/$_iconpath/kora-pgrey/$_iconcache"
+
+ install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
diff --git a/kora-icon-theme.install b/kora-icon-theme.install
new file mode 100644
index 000000000000..63bad7420c00
--- /dev/null
+++ b/kora-icon-theme.install
@@ -0,0 +1,16 @@
+_iconpath=usr/share/icons
+
+_gtk_icon_cache() {
+ gtk-update-icon-cache -f -t "/$_iconpath/kora/"
+ gtk-update-icon-cache -f -t "/$_iconpath/kora-light/"
+ gtk-update-icon-cache -f -t "/$_iconpath/kora-light-panel/"
+ gtk-update-icon-cache -f -t "/$_iconpath/kora-pgrey/"
+}
+
+post_install() {
+ _gtk_icon_cache
+}
+
+post_upgrade() {
+ _gtk_icon_cache
+}