summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordigitalone2019-04-24 11:36:17 +0200
committerdigitalone2019-04-24 11:36:17 +0200
commit05d519fc04dd0c24d11f92edd25309e99075154f (patch)
tree00756eb835c0e3365146f1b034431ce51f603ae6
parent1d156824d737c64af462982316a503e45dc07ebf (diff)
downloadaur-05d519fc04dd0c24d11f92edd25309e99075154f.tar.gz
fixed icons
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD31
2 files changed, 24 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f0d3b451d3a5..9ca263d08fb5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = korla-icon-theme
pkgdesc = Korla icon theme suitable for every desktop environment, dark and light versions
- pkgver = 1.0.3
- pkgrel = 3
+ pkgver = 1.0.4
+ pkgrel = 1
url = https://github.com/bikass/korla
install = korla-icon-theme.install
arch = any
@@ -10,8 +10,8 @@ pkgbase = korla-icon-theme
optdepends = hicolor-icon-theme: fallback Freedesktop.org Hicolor icon theme
optdepends = breeze-icons: fallback Breeze icon theme
optdepends = gnome-icon-theme: fallback Gnome icon theme
- source = https://github.com/bikass/korla/archive/v1.0.3.tar.gz
- md5sums = a52a1b62ed2dbed2223ea0ec41a97370
+ source = https://github.com/bikass/korla/archive/v1.0.4.tar.gz
+ md5sums = 0f4b5a01d225ed30cef90e44d51ae374
pkgname = korla-icon-theme
diff --git a/PKGBUILD b/PKGBUILD
index f530d93ff0f3..fa0893d869e7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Giusy Margarita <kurmikon at libero dot it>
pkgname=korla-icon-theme
-pkgver=1.0.3
-pkgrel=3
+pkgver=1.0.4
+pkgrel=1
pkgdesc="Korla icon theme suitable for every desktop environment, dark and light versions"
arch=("any")
url="https://github.com/bikass/korla"
@@ -14,11 +14,20 @@ optdepends=(
"gnome-icon-theme: fallback Gnome icon theme")
install="$pkgname.install"
source=("https://github.com/bikass/korla/archive/v$pkgver.tar.gz")
-md5sums=("a52a1b62ed2dbed2223ea0ec41a97370")
+md5sums=("0f4b5a01d225ed30cef90e44d51ae374")
_iconpath=usr/share/icons
+_iconcache=icon-theme.cache
package() {
+ cd "$srcdir/korla-$pkgver"
+
+ # Delete useless files from source folder
+ rm -f "korla/create-new-icon-theme.cache.sh"
+ rm -f "korla/$_iconcache"
+ rm -f "korla-light/create-new-icon-theme.cache.sh"
+ rm -f "korla-light/$_iconcache"
+
install -dm755 "$pkgdir/$_iconpath"
install -dm755 "$pkgdir/usr/share/doc/$pkgname"
install -dm755 "$pkgdir/usr/share/licenses/$pkgname"
@@ -27,16 +36,16 @@ package() {
# the theme locally and he messed with modes in the past making some icons unreadable
# and some directories not executable if installed system wide while he didn't notice
# any issue because he installed the theme under the local icon folder on his system.
- cd "$srcdir/korla-$pkgver"
cp -dr --no-preserve=mode "korla" "$pkgdir/$_iconpath/korla"
cp -dr --no-preserve=mode "korla-light" "$pkgdir/$_iconpath/korla-light"
- install -Dm644 "README.md" "$pkgdir/usr/share/doc/$pkgname/README.md"
- install -Dm644 "korla/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ # Create empty icon cache files, they will be filled during post_install and
+ # post_upgrade scripts
+ touch -a "$pkgdir/$_iconpath/korla/$_iconcache"
+ touch -a "$pkgdir/$_iconpath/korla-light/$_iconcache"
- cd "$pkgdir/$_iconpath"
- rm -f "korla/create-new-icon-theme.cache.sh"
- rm -f "korla-light/create-new-icon-theme.cache.sh"
- rm -f "korla/LICENSE"
- rm -f "korla-light/LICENSE"
+ install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 "README.md" "$pkgdir/usr/share/doc/$pkgname/README.md"
+ install -Dm644 "im1.png" "$pkgdir/usr/share/doc/$pkgname/im1.png"
+ install -Dm644 "im2.png" "$pkgdir/usr/share/doc/$pkgname/im2.png"
}