summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordigitalone2018-12-06 19:58:43 +0100
committerdigitalone2018-12-06 19:58:43 +0100
commit99d8992b7d36234e2e913f9cb890d2d8dfe3cb88 (patch)
treedefd56e8aa698984b18365dbb5226560a2bebbfc
downloadaur-99d8992b7d36234e2e913f9cb890d2d8dfe3cb88.tar.gz
first push
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD34
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..68a50a23ea2c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = korla-icon-theme
+ pkgdesc = Korla icon theme suitable for every desktop environment made by tarma
+ pkgver = 0.7.6
+ pkgrel = 1
+ url = https://www.opendesktop.org/p/1256209/
+ arch = any
+ license = GPL
+ makedepends = unzip
+ depends = gtk-update-icon-cache
+ optdepends = breeze-icons: fallback Breeze icon theme
+ optdepends = gnome-icon-theme: fallback Gnome icon theme
+ optdepends = hicolor-icon-theme: fallback Freedesktop.org Hicolor icon theme
+ source = https://dl.opendesktop.org/api/files/download/id/1544012871/s/8b017ca4e585bb4298ffeac86fd6443143b8c8ff7223dfbfd32392ff62aee634fc2a30b5c70aeb4c80409460488813c77cab4bf82ae28e2178a785fa8524407d/t/1544125932//korla%200-7-6.zip
+ md5sums = SKIP
+
+pkgname = korla-icon-theme
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a83a0229cb91
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Giusy Margarita <kurmikon at libero dot it>
+
+pkgname=korla-icon-theme
+pkgver=0.7.6
+pkgrel=1
+pkgdesc='Korla icon theme suitable for every desktop environment made by tarma'
+arch=('any')
+url='https://www.opendesktop.org/p/1256209/'
+license=('GPL')
+depends=('gtk-update-icon-cache')
+optdepends=('breeze-icons: fallback Breeze icon theme'
+ 'gnome-icon-theme: fallback Gnome icon theme'
+ 'hicolor-icon-theme: fallback Freedesktop.org Hicolor icon theme')
+makedepends=('unzip')
+
+# Hash and Timestamp
+_p="var \(hash = '\(.*\)\|timetamp = '\(.*\)\)';"
+read _s _t <<< $(echo -n $(curl -s $url | sed -n "s/$_p/\2\3/p" | head -n2))
+
+source=("https://dl.opendesktop.org/api/files/download/id/1544012871/s/$_s/t/$_t//korla%200-7-6.zip")
+md5sums=('SKIP')
+
+package() {
+ mkdir -p "$pkgdir/usr/share/icons/"
+
+ cp -r "$srcdir/korla" "$pkgdir/usr/share/icons/korla"
+
+ chmod 755 $(find "$pkgdir/usr/share/icons/korla" -type d)
+ chmod 644 $(find "$pkgdir/usr/share/icons/korla" -type f)
+}
+
+post_install() {
+ gtk-update-icon-cache -f -t "/usr/share/icons/korla/"
+}