summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJérôme Deuchnord2022-03-20 12:11:23 +0100
committerJérôme Deuchnord2022-03-20 12:11:23 +0100
commit711353408f8edef2b34693ae56c8a6e00f907d62 (patch)
tree0e090bb4b873a53edab7602e2875ea626395c324
parent4ca46f85ab02a89539e5b41c11b6a46e572ec71b (diff)
downloadaur-711353408f8edef2b34693ae56c8a6e00f907d62.tar.gz
Version 0.10.10
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD24
2 files changed, 15 insertions, 10 deletions
diff --git a/.gitignore b/.gitignore
index a37706531bb0..79ef94c15fa3 100644
--- a/.gitignore
+++ b/.gitignore
@@ -3,5 +3,4 @@
*.tar.gz
*.tar
/pkg
-/src
diff --git a/PKGBUILD b/PKGBUILD
index eb3b14bebaae..c79d1eb4ac9a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Jérôme Deuchnord <jerome@deuchnord.fr>
pkgname=kosmorro
-pkgver=0.10.9
+pkgver=0.10.10
pkgrel=1
pkgdesc='A program to calculate the ephemerides'
depends=(
@@ -10,6 +10,7 @@ depends=(
'python-termcolor'
'python-tabulate'
'python-dateutil'
+ 'python-babel'
)
optdepends=(
@@ -19,9 +20,7 @@ optdepends=(
makedepends=(
'python-pip'
- 'python-setuptools'
- 'python-wheel'
- 'python-babel'
+ 'python-poetry'
'ruby-ronn'
)
@@ -30,15 +29,22 @@ url='https://kosmorro.space'
license=('AGPL3')
source=("$pkgname-v$pkgver.tar.gz::https://codeload.github.com/Kosmorro/kosmorro/tar.gz/v$pkgver")
-sha256sums=("910109c4f8f6816e4f92f45f8fee63b5f47defb92b781ce26e0f1cfc2ed92f77")
+sha256sums=("20d41b6aab4293cfba41af5bef534b8b468dcaea1820f9c01f09b2540c511cd7")
build() {
cd "${srcdir}/kosmorro-${pkgver}"
- pybabel compile -d _kosmorro/locales
- make build
+ make i18n manpage build
}
package() {
- cd "${srcdir}/kosmorro-${pkgver}"
- python3 setup.py install --root="${pkgdir}/" --optimize=1 --skip-build
+ SOURCE_DIR="${srcdir}/kosmorro-${pkgver}"
+ PIP_CONFIG_FILE=/dev/null pip3 install --no-warn-script-location --isolated --ignore-installed --no-deps --root="${pkgdir}/" ${SOURCE_DIR}/dist/kosmorro-${pkgver}-py3-none-any.whl
+
+ mkdir -p "${pkgdir}/usr/share/man/man1" "${pkgdir}/usr/share/man/man7"
+ install "$SOURCE_DIR/manpage/kosmorro.1" "${pkgdir}/usr/share/man/man1/kosmorro.1"
+ install "$SOURCE_DIR/manpage/kosmorro.7" "${pkgdir}/usr/share/man/man7/kosmorro.7"
+
+ rm -rf ${pkgdir}/usr/lib/python3.10/site-packages/kosmorro/__pycache__
+ rm ${pkgdir}/usr/lib/python3.10/site-packages/kosmorro-${pkgver}.dist-info/direct_url.json
}
+