summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2016-09-02 16:22:22 +0200
committerAntonio Rojas2016-09-02 16:22:22 +0200
commitc250da35c2cf4f6393071b86aa7b710478e80513 (patch)
tree6d72f6b8e246c36dde8527702cacdd05519b9f9d
downloadaur-kqoauth.tar.gz
Move from extra
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD31
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6236eca54379
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Fri Sep 2 14:22:05 UTC 2016
+pkgbase = kqoauth
+ pkgdesc = A library written in C++ for Qt that implements the OAuth 1.0 authentication specification RFC 5849
+ pkgver = 0.98
+ pkgrel = 1
+ url = https://github.com/kypeli/kQOAuth
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = qt5-base
+ source = kqoauth-0.98.tar.gz::https://github.com/kypeli/kQOAuth/archive/0.98.tar.gz
+ sha1sums = b029c54000f818e01db3fbea447ec94d24fa594f
+
+pkgname = kqoauth
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8ba7073898ac
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# $Id: PKGBUILD 270955 2016-07-05 10:45:42Z arojas $
+# Maintainer: Antonio Rojas <arojas@archlinux.org>
+
+pkgname=kqoauth
+pkgver=0.98
+pkgrel=1
+pkgdesc="A library written in C++ for Qt that implements the OAuth 1.0 authentication specification RFC 5849"
+arch=(i686 x86_64)
+url='https://github.com/kypeli/kQOAuth'
+license=(GPL)
+depends=(qt5-base)
+source=($pkgname-$pkgver.tar.gz::"https://github.com/kypeli/kQOAuth/archive/$pkgver.tar.gz")
+sha1sums=('b029c54000f818e01db3fbea447ec94d24fa594f')
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+ qmake ../kQOAuth-$pkgver
+ make
+}
+
+package() {
+ cd build
+ make INSTALL_ROOT="$pkgdir" install
+
+ # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
+ find "$pkgdir/usr/lib" -type f -name '*.prl' -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
+}