summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosh Gwosdz2021-07-19 14:50:03 +0200
committerJosh Gwosdz2021-07-19 14:50:03 +0200
commitbb055bf6c9763198307f10ba0470f7c08b8334d5 (patch)
tree4d332b990934e35a946dfb670ce0e388832389bd
downloadaur-kubeflow-kfctl-bin.tar.gz
init with v1.2.0
Signed-off-by: Josh Gwosdz <jgwosdz@redhat.com>
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD19
3 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5ec5174ff208
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = kubeflow-kfctl-bin
+ pkgdesc = A tool to control and manage Kubeflow deployments
+ pkgver = 1.2.0
+ pkgrel = 1
+ url = https://github.com/kubeflow/kfctl
+ arch = x86_64
+ license = Apache
+ provides = kubeflow-kfctl
+ conflicts = kubeflow-kfctl
+ source = kubeflow-kfctl-bin-1.2.0.tar.gz::https://github.com/kubeflow/kfctl/releases/download/v1.2.0/kfctl_v1.2.0-0-gbc038f9_linux.tar.gz
+ sha256sums = 5e79d3eda986ed33fcab8536e038d566e90b8e990c9322b82843e1e2c54bb638
+
+pkgname = kubeflow-kfctl-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..001885e6ca19
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+src/
+pkg/
+
+*.tar.gz
+*.tar.zst
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ee17061cf24b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Josh Gwosdz <jgwosdz@redhat.com>
+pkgname=kubeflow-kfctl-bin
+pkgver=1.2.0
+_commit=gbc038f9
+pkgrel=1
+pkgdesc="A tool to control and manage Kubeflow deployments"
+arch=('x86_64')
+url="https://github.com/kubeflow/kfctl"
+depends=()
+makedepends=()
+provides=('kubeflow-kfctl')
+conflicts=('kubeflow-kfctl')
+license=('Apache')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/kubeflow/kfctl/releases/download/v${pkgver}/kfctl_v${pkgver}-0-${_commit}_linux.tar.gz")
+sha256sums=('5e79d3eda986ed33fcab8536e038d566e90b8e990c9322b82843e1e2c54bb638')
+
+package() {
+ install -Dm755 "$srcdir/kfctl" -T "$pkgdir/usr/bin/kfctl"
+}