summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSean Enck2018-07-08 10:08:32 -0400
committerSean Enck2018-07-08 10:08:32 -0400
commit38f2cf1c097a9bb053dcacf06a454bd63e585729 (patch)
treeaae6b5ae66aa97b8159571ec1f5c0890f3422a8b
parent776234ef352f59d4282d331646c99695eb26c380 (diff)
downloadaur-38f2cf1c097a9bb053dcacf06a454bd63e585729.tar.gz
use the upstream patch
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
-rw-r--r--kxstitch-qt5.11.patch48
3 files changed, 8 insertions, 56 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6e9a8e480a83..d706f372de89 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = kxstitch
pkgdesc = The program that lets you create cross stitch patterns and charts.
pkgver = 2.1.1
- pkgrel = 3
+ pkgrel = 4
url = https://userbase.kde.org/KXStitch
install = kxstitch.install
arch = i686
@@ -18,10 +18,10 @@ pkgbase = kxstitch
depends = imagemagick>=7.0.0
source = https://download.kde.org/stable/kxstitch/2.1.1/kxstitch-2.1.1.tar.xz
source = kxstitch.install
- source = kxstitch-qt5.11.patch
+ source = qt5.11.patch::https://cgit.kde.org/kxstitch.git/patch/?id=ca0f451dceecadc696ba6777084f22ceb5d372f0
sha1sums = 6f712bca3173b90149b67640fb1b63d02725c9ef
sha1sums = 8e58ce0776eff7ef29394a2f7a089191a4af0b1d
- sha1sums = 8c392224f4fa0ce5e036bc59cbe42c407649c663
+ sha1sums = 1d594501380c0ea1450c27696579fd5c74fe8461
pkgname = kxstitch
diff --git a/PKGBUILD b/PKGBUILD
index 7364a3cf9edd..dfb7fbf8be83 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor : enckse <enckse [at] gmail [dot] com>
pkgname=kxstitch
pkgver=2.1.1
-pkgrel=3
+pkgrel=4
pkgdesc="The program that lets you create cross stitch patterns and charts."
arch=('i686' 'x86_64')
depends=('plasma-workspace' 'imagemagick>=7.0.0')
@@ -11,18 +11,18 @@ url="https://userbase.kde.org/KXStitch"
license=('GPL')
source=("https://download.kde.org/stable/${pkgname}/${pkgver}/${pkgname}-${pkgver}.tar.xz"
"${pkgname}.install"
- "kxstitch-qt5.11.patch"
+ "qt5.11.patch::https://cgit.kde.org/kxstitch.git/patch/?id=ca0f451dceecadc696ba6777084f22ceb5d372f0"
)
sha1sums=('6f712bca3173b90149b67640fb1b63d02725c9ef'
'8e58ce0776eff7ef29394a2f7a089191a4af0b1d'
- '8c392224f4fa0ce5e036bc59cbe42c407649c663'
+ '1d594501380c0ea1450c27696579fd5c74fe8461'
)
install=${pkgname}.install
build() {
cd "${srcdir}/kxstitch-${pkgver}"
- cp ../kxstitch-qt5.11.patch .
- patch -p1 < kxstitch-qt5.11.patch
+ cp ../qt5.11.patch .
+ patch -p1 < qt5.11.patch
rm -rf build
mkdir build
cd build
diff --git a/kxstitch-qt5.11.patch b/kxstitch-qt5.11.patch
deleted file mode 100644
index 0e4c3f2b50ab..000000000000
--- a/kxstitch-qt5.11.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-diff --git a/src/LibraryPatternPropertiesDlg.cpp b/src/LibraryPatternPropertiesDlg.cpp
-index 8d2e24c..920ad25 100644
---- a/src/LibraryPatternPropertiesDlg.cpp
-+++ b/src/LibraryPatternPropertiesDlg.cpp
-@@ -15,6 +15,7 @@
- #include <KHelpClient>
- #include <KLocalizedString>
- #include <KSharedConfig>
-+#include <QIcon>
-
-
- LibraryPatternPropertiesDlg::LibraryPatternPropertiesDlg(QWidget *parent, qint32 key, Qt::KeyboardModifiers modifiers, qint16 baseline, const QString &scheme, int width, int height, const QIcon &icon)
-diff --git a/src/LibraryPatternPropertiesDlg.h b/src/LibraryPatternPropertiesDlg.h
-index e23d76c..46e8779 100644
---- a/src/LibraryPatternPropertiesDlg.h
-+++ b/src/LibraryPatternPropertiesDlg.h
-@@ -20,6 +20,7 @@
-
- class QHideEvent;
- class QShowEvent;
-+class QIcon;
-
-
- class LibraryPatternPropertiesDlg : public QDialog
-diff --git a/src/TextElementDlg.cpp b/src/TextElementDlg.cpp
-index 4d88b1e..be364a2 100644
---- a/src/TextElementDlg.cpp
-+++ b/src/TextElementDlg.cpp
-@@ -19,6 +19,7 @@
-
- #include <KHelpClient>
- #include <KLocalizedString>
-+#include <QButtonGroup>
-
- #include "Element.h"
-
-diff --git a/src/TextElementDlg.h b/src/TextElementDlg.h
-index 6e43012..002edcd 100644
---- a/src/TextElementDlg.h
-+++ b/src/TextElementDlg.h
-@@ -21,6 +21,7 @@
- class TextElement;
- class QHideEvent;
- class QShowEvent;
-+class QButtonGroup;
-
-
- class TextElementDlg : public QDialog