summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzoe2017-12-21 15:55:39 +0100
committerzoe2017-12-21 15:55:39 +0100
commit3b5fcc7fa1c30f1ef826d03248c47335f643c116 (patch)
tree4494a8fb96bcfea7647352b63d847cc5ed005d9e
parent7f2eac8751fa014233bbb339cb43688f2b872efe (diff)
downloadaur-3b5fcc7fa1c30f1ef826d03248c47335f643c116.tar.gz
apply imagemagick patch
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 11 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 130bb3abe0c9..d4a401200a5c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Tue Dec 27 20:10:15 UTC 2016
+# Thu Dec 21 14:54:52 UTC 2017
pkgbase = kxstitch
pkgdesc = The program that lets you create cross stitch patterns and charts.
pkgver = 2.0.0
- pkgrel = 2
+ pkgrel = 3
url = https://userbase.kde.org/KXStitch
install = kxstitch.install
arch = i686
@@ -19,8 +19,10 @@ pkgbase = kxstitch
depends = imagemagick
source = http://download.kde.org/stable/kxstitch/2.0.0/src/kxstitch-2.0.0.tar.xz
source = kxstitch.install
+ source = imagemagick.patch::https://github.com/KDE/kxstitch/commit/295773f44bfda1227d85edf065a8de14dc889159.diff
sha1sums = 3c0665ae6431632955aa00f416ebb8a34c7efcc3
sha1sums = 8e58ce0776eff7ef29394a2f7a089191a4af0b1d
+ sha1sums = e2d3c7ee0d9b62b7e0b1e4bcb327ee90f6edce3a
pkgname = kxstitch
diff --git a/PKGBUILD b/PKGBUILD
index af64854c0150..14a1bafdaa44 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
# Maintainer: zoe <chp321@gmail.com>
+# Contributor : enckse <enckse [at] gmail [dot] com>
pkgname=kxstitch
pkgver=2.0.0
-pkgrel=2
+pkgrel=3
pkgdesc="The program that lets you create cross stitch patterns and charts."
arch=('i686' 'x86_64')
depends=('plasma-workspace' 'imagemagick')
@@ -9,8 +10,9 @@ makedepends=('cmake' 'automoc4' 'doxygen' 'patch' 'extra-cmake-modules' 'kdoctoo
url="https://userbase.kde.org/KXStitch"
license=('GPL')
source=("http://download.kde.org/stable/${pkgname}/${pkgver}/src/${pkgname}-${pkgver}.tar.xz"
- "${pkgname}.install")
-sha1sums=('3c0665ae6431632955aa00f416ebb8a34c7efcc3' '8e58ce0776eff7ef29394a2f7a089191a4af0b1d')
+ "${pkgname}.install"
+ "imagemagick.patch::https://github.com/KDE/kxstitch/commit/295773f44bfda1227d85edf065a8de14dc889159.diff")
+sha1sums=('3c0665ae6431632955aa00f416ebb8a34c7efcc3' '8e58ce0776eff7ef29394a2f7a089191a4af0b1d' 'e2d3c7ee0d9b62b7e0b1e4bcb327ee90f6edce3a')
install=${pkgname}.install
build() {
@@ -20,6 +22,8 @@ build() {
# Avoid bug in cmake :
#sed -i '5i\cmake_policy(SET CMP0002 OLD)' CMakeLists.txt
+ cp ../imagemagick.patch .
+ patch -p1 < imagemagick.patch
rm -rf build
mkdir build
cd build