summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSean Enck2018-10-05 15:11:09 -0400
committerSean Enck2018-10-05 15:14:36 -0400
commit47d51a52da819ad04ca1bedae9e8072b67a3bbbf (patch)
treeffdf4a212747d1576f5395d3bfdf551591677013
parent9d4ccc6ac0d48692dace7f83dac940d1e4ac1d87 (diff)
downloadaur-47d51a52da819ad04ca1bedae9e8072b67a3bbbf.tar.gz
including a patch to specify imagemagick version as we're getting the wrong one with a libmagick6 conflict
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
-rw-r--r--imagemagick7.patch12
3 files changed, 23 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 12510fcea532..86905a3cff65 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = kxstitch
pkgdesc = The program that lets you create cross stitch patterns and charts.
pkgver = 2.1.1
- pkgrel = 6
+ pkgrel = 7
url = https://userbase.kde.org/KXStitch
install = kxstitch.install
arch = i686
@@ -18,9 +18,11 @@ pkgbase = kxstitch
source = https://download.kde.org/stable/kxstitch/2.1.1/kxstitch-2.1.1.tar.xz
source = kxstitch.install
source = qt5.11.patch::https://cgit.kde.org/kxstitch.git/patch/?id=ca0f451dceecadc696ba6777084f22ceb5d372f0
+ source = imagemagick7.patch
sha1sums = 6f712bca3173b90149b67640fb1b63d02725c9ef
sha1sums = 8e58ce0776eff7ef29394a2f7a089191a4af0b1d
sha1sums = d1a904efd34eca16d839d6d54356cb01abaa15a7
+ sha1sums = 59dc498eb3e555b0f85a717f0588b3a217f8cbbb
pkgname = kxstitch
diff --git a/PKGBUILD b/PKGBUILD
index 18a2d5122795..2582f4e97540 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor : enckse <enckse [at] gmail [dot] com>
pkgname=kxstitch
pkgver=2.1.1
-pkgrel=6
+pkgrel=7
pkgdesc="The program that lets you create cross stitch patterns and charts."
arch=('i686' 'x86_64')
depends=('plasma-workspace' 'imagemagick>=7.0.0')
@@ -12,21 +12,25 @@ license=('GPL')
source=("https://download.kde.org/stable/${pkgname}/${pkgver}/${pkgname}-${pkgver}.tar.xz"
"${pkgname}.install"
"qt5.11.patch::https://cgit.kde.org/kxstitch.git/patch/?id=ca0f451dceecadc696ba6777084f22ceb5d372f0"
- )
+ "imagemagick7.patch")
sha1sums=('6f712bca3173b90149b67640fb1b63d02725c9ef'
'8e58ce0776eff7ef29394a2f7a089191a4af0b1d'
'd1a904efd34eca16d839d6d54356cb01abaa15a7'
- )
+ '59dc498eb3e555b0f85a717f0588b3a217f8cbbb')
install=${pkgname}.install
build() {
cd "${srcdir}/kxstitch-${pkgver}"
- cp ../qt5.11.patch .
+ cp ../*.patch .
patch -p1 < qt5.11.patch
+ patch -p1 < imagemagick7.patch
rm -rf build
mkdir build
cd build
cmake -DCMAKE_INSTALL_PREFIX=`qtpaths --install-prefix` .. \
+ -DImageMagick_Magick++_INCLUDE_DIRS=/usr/include/ImageMagick-7 \
+ -DImageMagick_Magick++_LIBRARY=/usr/lib/libMagick++-7.Q16HDRI.so \
+ -DImageMagick_MagickCore_LIBRARY=/usr/lib/libMagickCore-7.Q16HDRI.so \
-DCMAKE_BUILD_TYPE="Release"
make
}
diff --git a/imagemagick7.patch b/imagemagick7.patch
new file mode 100644
index 000000000000..e96ffa2fb0e3
--- /dev/null
+++ b/imagemagick7.patch
@@ -0,0 +1,12 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 5eb5f73..8fa5678 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -37,7 +37,6 @@ find_package (KF5 REQUIRED COMPONENTS
+ XmlGui
+ )
+
+-find_package (ImageMagick COMPONENTS MagickCore Magick++ REQUIRED)
+ find_package (X11 REQUIRED)
+ find_package (Doxygen)
+ find_package (SharedMimeInfo)