summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzoe2018-01-20 18:38:02 +0100
committerzoe2018-01-20 18:38:02 +0100
commit4dccdce2aeadf608498744ef1268025cc8b03314 (patch)
tree58a882ab26a9ba75cbe683af5f990269c94d9a1c
parent3b5fcc7fa1c30f1ef826d03248c47335f643c116 (diff)
downloadaur-4dccdce2aeadf608498744ef1268025cc8b03314.tar.gz
Update to 2.1.0
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD15
2 files changed, 12 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d4a401200a5c..77937d581ecf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Thu Dec 21 14:54:52 UTC 2017
+# Sat Jan 20 17:37:33 UTC 2018
pkgbase = kxstitch
pkgdesc = The program that lets you create cross stitch patterns and charts.
- pkgver = 2.0.0
- pkgrel = 3
+ pkgver = 2.1.0
+ pkgrel = 1
url = https://userbase.kde.org/KXStitch
install = kxstitch.install
arch = i686
@@ -17,12 +17,10 @@ pkgbase = kxstitch
makedepends = kdoctools
depends = plasma-workspace
depends = imagemagick
- source = http://download.kde.org/stable/kxstitch/2.0.0/src/kxstitch-2.0.0.tar.xz
+ source = https://download.kde.org/stable/kxstitch/2.1.0/kxstitch-2.1.0.tar.xz
source = kxstitch.install
- source = imagemagick.patch::https://github.com/KDE/kxstitch/commit/295773f44bfda1227d85edf065a8de14dc889159.diff
- sha1sums = 3c0665ae6431632955aa00f416ebb8a34c7efcc3
+ sha1sums = b1a98ecc8262f69c5e7aae0677546210b52fca08
sha1sums = 8e58ce0776eff7ef29394a2f7a089191a4af0b1d
- sha1sums = e2d3c7ee0d9b62b7e0b1e4bcb327ee90f6edce3a
pkgname = kxstitch
diff --git a/PKGBUILD b/PKGBUILD
index 14a1bafdaa44..a9cb1509d0af 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,17 @@
# Maintainer: zoe <chp321@gmail.com>
# Contributor : enckse <enckse [at] gmail [dot] com>
pkgname=kxstitch
-pkgver=2.0.0
-pkgrel=3
+pkgver=2.1.0
+pkgrel=1
pkgdesc="The program that lets you create cross stitch patterns and charts."
arch=('i686' 'x86_64')
depends=('plasma-workspace' 'imagemagick')
makedepends=('cmake' 'automoc4' 'doxygen' 'patch' 'extra-cmake-modules' 'kdoctools')
url="https://userbase.kde.org/KXStitch"
license=('GPL')
-source=("http://download.kde.org/stable/${pkgname}/${pkgver}/src/${pkgname}-${pkgver}.tar.xz"
- "${pkgname}.install"
- "imagemagick.patch::https://github.com/KDE/kxstitch/commit/295773f44bfda1227d85edf065a8de14dc889159.diff")
-sha1sums=('3c0665ae6431632955aa00f416ebb8a34c7efcc3' '8e58ce0776eff7ef29394a2f7a089191a4af0b1d' 'e2d3c7ee0d9b62b7e0b1e4bcb327ee90f6edce3a')
+source=("https://download.kde.org/stable/${pkgname}/${pkgver}/${pkgname}-${pkgver}.tar.xz"
+ "${pkgname}.install")
+sha1sums=('b1a98ecc8262f69c5e7aae0677546210b52fca08' '8e58ce0776eff7ef29394a2f7a089191a4af0b1d')
install=${pkgname}.install
build() {
@@ -22,8 +21,8 @@ build() {
# Avoid bug in cmake :
#sed -i '5i\cmake_policy(SET CMP0002 OLD)' CMakeLists.txt
- cp ../imagemagick.patch .
- patch -p1 < imagemagick.patch
+ #cp ../imagemagick.patch .
+ #patch -p1 < imagemagick.patch
rm -rf build
mkdir build
cd build