summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzoe2015-06-25 08:57:59 +0200
committerzoe2015-06-25 08:57:59 +0200
commit8d1b1ec1dd9fe6784658226ece7dafd101bfc12e (patch)
treeac8d67c600d3b8d590aecc93eed86e253bc74258
downloadaur-8d1b1ec1dd9fe6784658226ece7dafd101bfc12e.tar.gz
Initial import
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD32
-rw-r--r--kxstitch.install13
3 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..190f7a1b056e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = kxstitch
+ pkgdesc = The program that lets you create cross stitch patterns and charts.
+ pkgver = 1.2.0
+ pkgrel = 4
+ url = http://kxstitch.sourceforge.net/
+ install = kxstitch.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = cmake
+ makedepends = automoc4
+ makedepends = doxygen
+ makedepends = patch
+ depends = kdebase-runtime
+ depends = imagemagick
+ source = http://www-ftp.lip6.fr/pub/X11/kde/stable/kxstitch/1.2.0/src/kxstitch-1.2.0.tar.bz2
+ source = kxstitch.install
+ md5sums = b6b33dcfc30ec9df81b9df2c4edd4d24
+ md5sums = 5b554364ee8db32e0bb1e881bf0bca34
+
+pkgname = kxstitch
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5b656423a508
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: zoe <chp321@gmail.com>
+pkgname=kxstitch
+pkgver=1.2.0
+pkgrel=4
+pkgdesc="The program that lets you create cross stitch patterns and charts."
+arch=('i686' 'x86_64')
+depends=('kdebase-runtime' 'imagemagick')
+makedepends=('cmake' 'automoc4' 'doxygen' 'patch')
+url="http://kxstitch.sourceforge.net/"
+license=('GPL')
+source=(http://www-ftp.lip6.fr/pub/X11/kde/stable/kxstitch/${pkgver}/src/kxstitch-${pkgver}.tar.bz2 kxstitch.install)
+md5sums=('b6b33dcfc30ec9df81b9df2c4edd4d24' '5b554364ee8db32e0bb1e881bf0bca34')
+install=kxstitch.install
+
+build() {
+ cd "$srcdir/kxstitch-${pkgver}"
+ sed -i 's/-DMAGICKCORE_HDRI_ENABLE=0/-DMAGICKCORE_HDRI_ENABLE=1/' CMakeLists.txt
+ rm -rf build
+ mkdir build
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX=`kde4-config --prefix` .. \
+ -DCMAKE_BUILD_TYPE="Release"
+ make
+}
+
+package() {
+ cd "$srcdir/kxstitch-${pkgver}/build"
+ make DESTDIR="${pkgdir}" install
+
+ # this one is unnecessary and namcap hates this dangling link
+ #rm "${pkgdir}/usr/share/doc/kde/html/en/kxstitch/common"
+} \ No newline at end of file
diff --git a/kxstitch.install b/kxstitch.install
new file mode 100644
index 000000000000..4271af20f492
--- /dev/null
+++ b/kxstitch.install
@@ -0,0 +1,13 @@
+post_install() {
+ update-desktop-database -q
+ update-mime-database usr/share/mime
+ xdg-icon-resource forceupdate
+}
+
+post_remove() {
+ update-desktop-database -q
+ update-mime-database usr/share/mime
+ xdg-icon-resource forceupdate
+}
+
+# vim:set ts=2 sw=2 et: