summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Schumacher2024-10-06 13:11:38 +0200
committerTim Schumacher2024-10-06 13:11:38 +0200
commit79d9b14965d46a96001f0660b8a8426963dc129f (patch)
treecc645353be5c887b0bd2b6fb46b2e6d758945d9a
parent88db80e5d24318650457e91f267965619822e55c (diff)
downloadaur-79d9b14965d46a96001f0660b8a8426963dc129f.tar.gz
Remove headers, update license name
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD29
2 files changed, 24 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9b831b3ab9d1..8e10254abda8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
pkgbase = ladybird
pkgdesc = Truly independent web browser
- pkgver = 20240716
+ pkgver = 20241006
pkgrel = 1
url = https://github.com/LadybirdBrowser/ladybird
arch = x86_64
- license = BSD
+ license = BSD-2-Clause
makedepends = git
makedepends = cmake
makedepends = ninja
@@ -23,11 +23,11 @@ pkgbase = ladybird
depends = ttf-liberation
options = !lto
options = !debug
- source = git+https://github.com/LadybirdBrowser/ladybird#commit=bfc9dc447f42eb9d7d0927721291d1b528b3125d
- source = git+https://github.com/microsoft/vcpkg.git#commit=f7423ee180c4b7f40d43402c2feb3859161ef625
+ source = git+https://github.com/LadybirdBrowser/ladybird#commit=5056bda043984953685bb4284fc698ab42418045
+ source = git+https://github.com/microsoft/vcpkg.git#commit=2960d7d80e8d09c84ae8abf15c12196c2ca7d39a
source = ladybird.desktop
- b2sums = SKIP
- b2sums = SKIP
- b2sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
pkgname = ladybird
diff --git a/PKGBUILD b/PKGBUILD
index 07f42ff444bc..b9b0a7cd62c5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,21 +3,25 @@
# Contributor: Brian <brain@derelict.garden>
pkgname=ladybird
-pkgver=20240716
+pkgver=20241006
pkgrel=1
pkgdesc='Truly independent web browser'
arch=(x86_64)
url='https://github.com/LadybirdBrowser/ladybird'
-license=(BSD)
+license=(BSD-2-Clause)
depends=(ffmpeg libgl qt6-base qt6-tools qt6-wayland qt6-multimedia ttf-liberation)
makedepends=(git cmake ninja curl unzip zip tar autoconf-archive nasm)
-options=(!lto !debug)
-source=("git+$url#commit=bfc9dc447f42eb9d7d0927721291d1b528b3125d" # 2024-07-16
- "git+https://github.com/microsoft/vcpkg.git#commit=f7423ee180c4b7f40d43402c2feb3859161ef625" # 2024-06-15 (Toolchain/BuildVcpkg.sh)
- "ladybird.desktop")
-b2sums=('SKIP'
- 'SKIP'
- 'SKIP')
+options=('!lto' '!debug')
+source=(
+ "git+$url#commit=5056bda043984953685bb4284fc698ab42418045" # 2024-10-06
+ "git+https://github.com/microsoft/vcpkg.git#commit=2960d7d80e8d09c84ae8abf15c12196c2ca7d39a" # 2024-09-30 (Toolchain/BuildVcpkg.sh)
+ "ladybird.desktop"
+)
+sha256sums=(
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+)
build() {
cd "${srcdir}"
@@ -31,6 +35,7 @@ build() {
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX='/usr' \
-DCMAKE_TOOLCHAIN_FILE="${VCPKG_ROOT}/scripts/buildsystems/vcpkg.cmake" \
+ -DENABLE_INSTALL_HEADERS=OFF \
-GNinja \
-Wno-dev
ninja -C build
@@ -41,8 +46,8 @@ package() {
DESTDIR="${pkgdir}" ninja -C build install
- install -Dm644 "${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
- install -Dm644 "ladybird/Base/res/icons/128x128/app-browser.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+ install -Dm644 "ladybird.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ install -Dm644 "ladybird/Base/res/icons/128x128/app-browser.png" "${pkgdir}/usr/share/pixmaps/ladybird.png"
- install -Dm644 ladybird/LICENSE -t "${pkgdir}/usr/share/licenses/ladybird/"
+ install -Dm644 ladybird/LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}/"
}