summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryuhldr2024-12-25 09:51:25 +0800
committeryuhldr2024-12-25 09:51:25 +0800
commit4b385cd785ef41db81b4e4b93c098ce8d71362ff (patch)
treed14dbd0ce95d398325ad1b27c9985152fd9c6d70
parentb29b9fdebfca564e6262bda070b609c7d262c87a (diff)
downloadaur-4b385cd785ef41db81b4e4b93c098ce8d71362ff.tar.gz
fix: py3.13 and remove lammps-gui
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD28
2 files changed, 17 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d73713b71e3a..7317f38eb66d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = lammps
pkgdesc = Public development project of the LAMMPS MD software package
pkgver = 20240829
- pkgrel = 2
+ pkgrel = 3
url = https://lammps.org
arch = x86_64
license = GPL
@@ -13,7 +13,7 @@ pkgbase = lammps
depends = ffmpeg
depends = libpng
depends = python
- depends = qt6-charts
+ depends = intel-oneapi-mkl
optdepends = clang
optdepends = python
optdepends = python-mpi4py
diff --git a/PKGBUILD b/PKGBUILD
index fbdab2d76b9a..904b0ea56979 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,12 +6,12 @@
pkgname=lammps
pkgver=20240829
_pkgver="stable_29Aug2024_update1"
-pkgrel=2
+pkgrel=3
pkgdesc="Public development project of the LAMMPS MD software package"
url="https://lammps.org"
arch=('x86_64')
license=('GPL')
-depends=('fftw' 'openmpi' 'ffmpeg' 'libpng' 'python' 'qt6-charts')
+depends=('fftw' 'openmpi' 'ffmpeg' 'libpng' 'python' 'intel-oneapi-mkl')
makedepends=('cmake>=3.1' 'python-pip' 'python-build')
conflicts=('lammps-git')
provides=('lammps')
@@ -38,13 +38,14 @@ build() {
-D LAMMPS_EXCEPTIONS=on \
-D BUILD_LIB=on \
-D BUILD_SHARED_LIBS=on \
- -D BUILD_LAMMPS_GUI=on \
-D CMAKE_BUILD_TYPE=Release \
-D CMAKE_INSTALL_PREFIX="/usr" \
-D CMAKE_INSTALL_LIBDIR="lib" \
-D CMAKE_INSTALL_LIBEXECDIR="/usr/lib" \
../cmake
+ # -D BUILD_LAMMPS_GUI=on \
+
cmake --build . -j $(($(nproc) - 1))
cd ../tools/phonon/
@@ -53,6 +54,7 @@ build() {
# python lib
cd ../../python/
+ rm -rf dist
python -m build
}
@@ -60,25 +62,25 @@ package() {
cd ${pkgname}-${_pkgver}/build
make DESTDIR="${pkgdir}" install
- mkdir -p "${pkgdir}/usr/share/examples/lammps"
- cp -r "../examples/." "${pkgdir}/usr/share/examples/lammps/"
- cp -r "../python/examples" "${pkgdir}/usr/share/examples/lammps/python/more"
- find "${pkgdir}/usr/share/examples/lammps/" -type f -exec chmod 644 '{}' +
+ # mkdir -p "${pkgdir}/usr/share/examples/lammps"
+ # cp -r "../examples/." "${pkgdir}/usr/share/examples/lammps/"
+ # cp -r "../python/examples" "${pkgdir}/usr/share/examples/lammps/python/more"
+ # find "${pkgdir}/usr/share/examples/lammps/" -type f -exec chmod 644 '{}' +
install -Dm644 "../tools/vim/lammps.vim" "${pkgdir}/usr/share/vim/vimfiles/syntax/lammps.vim"
install -Dm644 "../tools/vim/filetype.vim" "${pkgdir}/usr/share/vim/vimfiles/ftdetect/lammps.vim"
- # install -Dm644 "../tools/kate/lammps.xml" "${pkgdir}/usr/share/katepart5/syntax/lammps.xml"
+
install -Dm755 "../tools/phonon/build/phana" "${pkgdir}/usr/bin/phana"
# python lib
PIP_CONFIG_FILE=/dev/null pip install --isolated --root="$pkgdir" --ignore-installed --no-deps ../python/dist/*.whl
# 遍历以 lib 开头的文件
- for file in "${pkgdir}/usr/lib/lib"*; do
- # 如果文件不是 liblammps,则删除
- [[ "$(basename "$file")" == liblammps* ]] || rm -f "$file"
- done
- rm -f ${pkgdir}/usr/lib/ld-linux*
+ # for file in "${pkgdir}/usr/lib/lib"*; do
+ # # 如果文件不是 liblammps,则删除
+ # [[ "$(basename "$file")" == liblammps* ]] || rm -f "$file"
+ # done
+ # rm -f ${pkgdir}/usr/lib/ld-linux*
}