summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorphyskets2019-03-18 13:50:32 +0530
committerphyskets2019-03-18 13:50:32 +0530
commit690c171991c7bcb19f88d668bc41f73a480d198e (patch)
treebcbd8cb75f86c47fb741076eef014207bfbb4ed0
parent525368d9280d05c786febc4abaf3303d7649c763 (diff)
downloadaur-690c171991c7bcb19f88d668bc41f73a480d198e.tar.gz
change deps and build docs by default
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD18
2 files changed, 10 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fa935518db6b..f6d9b796bd23 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,15 @@
pkgbase = lammps-beta
- pkgdesc = Large-scale Atomic/Molecular Massively Parallel Simulator.
+ pkgdesc = Large-scale Atomic/Molecular Massively Parallel Simulator
pkgver = 20190228
pkgrel = 3
- url = http://lammps.sandia.gov/
+ url = https://lammps.sandia.gov/
arch = x86_64
license = GPL
makedepends = cmake
+ makedepends = python-sphinx
+ makedepends = lammpsdoc
depends = fftw
depends = openmpi
- optdepends = kim-api: support for OpenKIM potentials
- optdepends = python-sphinx: install to build documentation
- optdepends = lammpsdoc: install to build documentation
provides = lammps
conflicts = lammps
source = lammps-28Feb2019.tar.gz::https://github.com/lammps/lammps/archive/patch_28Feb2019.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 5fd1901119a0..84d3f7fdd216 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,25 +5,19 @@ pkgname=${_pkgname}-beta
pkgver=20190228
_pkgver=$(date -d ${pkgver} +%-d%b%Y)
pkgrel=3
-pkgdesc="Large-scale Atomic/Molecular Massively Parallel Simulator."
-url="http://lammps.sandia.gov/"
+pkgdesc="Large-scale Atomic/Molecular Massively Parallel Simulator"
+url="https://lammps.sandia.gov/"
arch=('x86_64')
license=('GPL')
depends=('fftw' 'openmpi')
-makedepends=('cmake')
-optdepends=('kim-api: support for OpenKIM potentials'
- 'python-sphinx: install to build documentation'
- 'lammpsdoc: install to build documentation')
+makedepends=('cmake' 'python-sphinx' 'lammpsdoc')
conflicts=('lammps')
provides=('lammps')
source=("${_pkgname}-${_pkgver}.tar.gz::https://github.com/${_pkgname}/${_pkgname}/archive/patch_${_pkgver}.tar.gz")
sha512sums=('dc264ec43a5a917a0a7905f89076c2e10e8d5613bb710fb970eb388721860d7d409db7d988803bde823ddd74691c4b3bdf5bf4a72713476dad5a4b0833a4dbd0')
-_BUILD_DOC=false
-# Set the above to 'true' if you want local documentation
-# You will also have to install the relevant optional dependencies
-# 'python-sphinx' is in the repos,
-# while lammpsdoc is available via the AUR package 'lammpsdoc-git'
+_BUILD_DOC=true
+# Set the above to 'false' if you want to build documentation
prepare(){
cd "${_pkgname}-patch_${_pkgver}"
@@ -36,7 +30,7 @@ build() {
-DCMAKE_INSTALL_PREFIX="/usr" \
-DCMAKE_INSTALL_LIBDIR="lib" \
-DCMAKE_INSTALL_LIBEXECDIR="/usr/lib" #\
- #-DPKG_KIM=yes # KIM package
+ #-DPKG_KIM=yes # KIM package. Also install 'kim-api' from the AUR
# Add options for additional packages
#-DPKG_<NAME>=yes