summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPierre-Marie de Rodat2021-01-24 16:35:06 +0100
committerPierre-Marie de Rodat2021-01-24 16:35:06 +0100
commit8f14347632a7a2554c323c5612251ac921ffa9ee (patch)
tree532671a37b4ffd10c2feb634bbfc8ae67208df2d
parent470b9ce5fe951cf4ebc92fe935c996569cd3ba9c (diff)
downloadaur-langkit-git.tar.gz
Update for recent versions
* Use the new manage.py script to build and install langkit_support. * Build and install static libraries, now that the GPRconfig/GPRbuild bug for -r/-pie conflicts is fixed.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD21
2 files changed, 10 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ac503fc13c84..56b62fe2ab2e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = langkit-git
pkgdesc = Compiler for syntactic and semantic language analysis libraries
- pkgver = r6816.55fe04716
+ pkgver = r7153.b32ae90dc
pkgrel = 1
url = https://github.com/AdaCore/langkit/
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index 699248173622..3e69b9cdcdf9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Pierre-Marie de Rodat <pmderodat on #ada at freenode.net>
pkgname=langkit-git
-pkgver=r6816.55fe04716
+pkgver=r7153.b32ae90dc
pkgrel=1
pkgdesc='Compiler for syntactic and semantic language analysis libraries'
@@ -36,14 +36,10 @@ build()
# Build the Langkit_Support library, used by all Langkit-generated
# libraries.
- #
- # TODO: build & install static libraries. For now, this fails because
- # auto-initialized static libraries are built using partial linking (ld's
- # -r option), which conflicts with GCC's by default -pie option.
- python scripts/build-langkit_support.py generate
- python scripts/build-langkit_support.py \
- --library-types relocatable \
- build --build-mode=prod --gargs="-R"
+ python manage.py build-langkit-support \
+ --library-types=static,static-pic,relocatable \
+ --build-mode=prod \
+ --gargs="-R"
}
package()
@@ -51,7 +47,8 @@ package()
cd "$srcdir/${pkgname%-git}"
python setup.py install --root="$pkgdir"
- python scripts/build-langkit_support.py \
- --library-types relocatable \
- install --build-mode=prod "$pkgdir/usr"
+ python manage.py install-langkit-support \
+ --library-types=static,static-pic,relocatable \
+ --build-mode=prod \
+ "$pkgdir/usr"
}