summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorczk2016-10-27 11:42:36 +0200
committerczk2016-10-27 11:42:36 +0200
commit8e53d18b708f6a36948cf5f413057d64322d056f (patch)
treeb363c9afa9ed8ded59c14836e078b18385baa0de
parentd2bfdebab1029426cf43eb1a9ff76caee8803b8b (diff)
downloadaur-laszip.tar.gz
Cosmetics.
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD25
2 files changed, 21 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 56b0d6299b23..9e0a233133ba 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,15 @@
+# Generated by mksrcinfo v8
+# Thu Oct 27 09:39:22 UTC 2016
pkgbase = laszip
- pkgdesc = Quickly turns bulky LAS files into compact LAZ files without information loss.
+ pkgdesc = ASPRS LAS lossless compression library.
pkgver = 2.2.0
- pkgrel = 4
- url = http://www.laszip.org/
+ pkgrel = 5
+ url = http://www.laszip.org
arch = i686
arch = x86_64
license = LGPL
- source = https://github.com/LASzip/LASzip/releases/download/v2.2.0/laszip-src-2.2.0.tar.gz
- md5sums = 1693724d8284dc04f04eb0b86f7de2cc
+ source = http://download.osgeo.org/laszip/laszip-src-2.2.0.tar.bz2
+ md5sums = 93194700623f6aca470454299361e89d
pkgname = laszip
diff --git a/PKGBUILD b/PKGBUILD
index 4c529d0a0d1f..86a115eee4f9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,23 @@
-pkgname=laszip
-pkgver=2.2.0
-pkgrel=4
-pkgdesc="Quickly turns bulky LAS files into compact LAZ files without information loss."
+# Maintainer: Maciej Sieczka <msieczka at sieczka dot org>
+# Contributor: Michael <mbostwick89@gmail.com>
+
+pkgname='laszip'
+pkgver='2.2.0'
+pkgrel='5'
+pkgdesc='ASPRS LAS lossless compression library.'
arch=('i686' 'x86_64')
-url="http://www.laszip.org/"
+url='http://www.laszip.org'
license=('LGPL')
-source=(https://github.com/LASzip/LASzip/releases/download/v$pkgver/$pkgname-src-$pkgver.tar.gz)
-md5sums=('1693724d8284dc04f04eb0b86f7de2cc')
+source=("http://download.osgeo.org/laszip/${pkgname}-src-${pkgver}.tar.bz2")
+md5sums=('93194700623f6aca470454299361e89d')
build() {
- cd "$srcdir/$pkgname-src-$pkgver"
- ./configure --prefix=/usr --includedir=/usr/include/${pkgname}
+ cd "${srcdir}/${pkgname}-src-${pkgver}"
+ ./configure --prefix='/usr' --includedir="/usr/include/${pkgname}"
make
}
package() {
- cd "$srcdir/$pkgname-src-$pkgver"
- make DESTDIR="$pkgdir/" install
+ cd "${srcdir}/${pkgname}-src-${pkgver}"
+ make DESTDIR="$pkgdir" install
}