aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrey Novikov2019-05-07 14:42:17 +0300
committerAndrey Novikov2019-05-07 14:42:17 +0300
commit648464a1eb13c3904312fdf0998725ccfdf474f5 (patch)
tree0be68600367aabc72f02bb9818a2a75e7a862d46
downloadaur-648464a1eb13c3904312fdf0998725ccfdf474f5.tar.gz
Publish lefthook version 0.3.1 to AUR
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD26
-rw-r--r--README.md20
4 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c81206b7a3a1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = lefthook
+ pkgdesc = git hooks manager
+ pkgver = 0.3.1
+ pkgrel = 1
+ url = https://github.com/Arkweid/lefthook
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = go
+ makedepends = rsync
+ source = https://github.com/Arkweid/lefthook/archive/v0.3.1.tar.gz
+ sha256sums = c173ae7e5ef1fca145ea042eb5360536806d9e2f8dabdf960dda68207ed633ca
+
+pkgname = lefthook
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..17ac5abc4ae3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+*.pkg.tar.xz
+*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3b3bb42cffb6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Andrey Novikov <envek@envek.name>
+
+pkgname=lefthook
+pkgdesc="git hooks manager"
+pkgver=0.3.1
+pkgrel=1
+arch=('i686' 'x86_64')
+url="https://github.com/Arkweid/lefthook"
+license=('MIT')
+makedepends=('go' 'rsync')
+source=("https://github.com/Arkweid/lefthook/archive/v${pkgver}.tar.gz")
+sha256sums=('c173ae7e5ef1fca145ea042eb5360536806d9e2f8dabdf960dda68207ed633ca')
+
+build() {
+ cd "$pkgname-$pkgver"
+ go build \
+ -gcflags "all=-trimpath=${PWD}" \
+ -asmflags "all=-trimpath=${PWD}" \
+ -ldflags "-extldflags ${LDFLAGS}" \
+ .
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm755 $pkgname "$pkgdir"/usr/bin/$pkgname
+} \ No newline at end of file
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..9aded14d2a8f
--- /dev/null
+++ b/README.md
@@ -0,0 +1,20 @@
+# lefthook
+
+git hooks manager written in Go.
+
+## Upgrading
+
+ 1. Change version and checksum in `PKGBUILD` according to git tag and source code archive checksum published in https://github.com/anycable/anycable-go/releases/
+
+ 2. Update `.SRCINFO` file:
+
+ ```sh
+ makepkg --printsrcinfo > .SRCINFO
+ ```
+ 3. Build package
+
+ ```sh
+ makepkg
+ ```
+
+ 4. Commit and push changes