summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorphosphenius2018-07-23 23:53:33 +0200
committerphosphenius2018-07-23 23:53:33 +0200
commit0a0988869c271d8162f0486b67f1447a620af077 (patch)
tree7fa3aa82236019ad507bcc77e35ef9e65acbfb30
downloadaur-lerpc.tar.gz
Initial import
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD22
3 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f4ef2030d41d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = lerpc
+ pkgdesc = Does linear interpolation (lerp) between HTML color codes
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/Phosphenius/lerpc
+ arch = any
+ license = MIT
+ source = https://github.com/Phosphenius/lerpc/archive/v0.1.0.tar.gz
+ md5sums = ff9d3408f3be689285566ea2046ae4d5
+
+pkgname = lerpc
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..37ad42025a9d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+*.tar.*
+/src/
+/pkg/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5f52765a1ff5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Phosphenius <luca dot kredel at web dot de>
+pkgname=lerpc
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Does linear interpolation (lerp) between HTML color codes"
+arch=('any')
+url="https://github.com/Phosphenius/lerpc"
+license=('MIT')
+source=("https://github.com/Phosphenius/$pkgname/archive/v$pkgver.tar.gz")
+md5sums=('ff9d3408f3be689285566ea2046ae4d5')
+
+build() {
+ cd "$pkgname-$pkgver"
+
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ make DESTDIR="$pkgdir/" install
+}