summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimone Riva2015-06-08 12:43:30 +0200
committerSimone Riva2015-06-08 12:43:30 +0200
commita4303b33c60f90afc91cf62d70c3af61798e815c (patch)
tree17fffaf31e2b11f8a7f77796430ffbe1df8735da
downloadaur-lescienze500.tar.gz
port to aur4
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD22
-rw-r--r--lescienze500.install5
3 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0e55efd78f45
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = lescienze500
+ pkgdesc = Un software per consultare, cercare e catalogare gli articoli dei 500 numeri di Le Scienze
+ pkgver = 1.3.6
+ pkgrel = 4
+ url = http://lescienze500.wordpress.com/
+ install = lescienze500.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = qt4
+ depends = sqlite
+ source = https://github.com/downloads/simon-r/LeScienze500/lescienze500-1.3.6.tar.gz
+ md5sums = 1596cd3a09fd82b34751bf686f91b948
+
+pkgname = lescienze500
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e52242323eac
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+pkgname=lescienze500
+pkgver=1.3.6
+pkgrel=4
+pkgdesc="Un software per consultare, cercare e catalogare gli articoli dei 500 numeri di Le Scienze"
+arch=('i686' 'x86_64')
+url="http://lescienze500.wordpress.com/"
+license=('GPL')
+depends=('qt4' 'sqlite')
+install=lescienze500.install
+source=("https://github.com/downloads/simon-r/LeScienze500/${pkgname}-${pkgver}.tar.gz")
+md5sums=('1596cd3a09fd82b34751bf686f91b948')
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ qmake-qt4 ./LeScienze500.pro -r -spec linux-g++
+ make
+}
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ make INSTALL_ROOT=${pkgdir} install
+}
diff --git a/lescienze500.install b/lescienze500.install
new file mode 100644
index 000000000000..4bec879baa5f
--- /dev/null
+++ b/lescienze500.install
@@ -0,0 +1,5 @@
+
+post_install() {
+ xdg-icon-resource forceupdate --theme hicolor &
+}
+