summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandre Demers2020-06-21 12:26:32 -0400
committerAlexandre Demers2020-06-21 12:26:32 -0400
commit67b2ff22da2046f0ee0c51ab4ace43c2edc04ca3 (patch)
tree0be81308e41b859c199ed448809378f8f9ac4bc3
parent544bc7d621eb88d7e8bf7471b114fd57425c8b70 (diff)
downloadaur-67b2ff22da2046f0ee0c51ab4ace43c2edc04ca3.tar.gz
Fix license warning + keep bin content
This package is not a library only package. It contains a executable file under the bin folder. Thus, we should keep it, with the proper suffix. Otherwise, we would need to rename the package to lib32-libdav1d to make the distinction, stating that it provides lib32-dav1d. Doing so would only be partially true though, since it would be a subset of the full content. Some other distros choose to provide splitted packages to distinguish between libraries and executables / programs. When/if the package is splitted in the future to propose a library and an executable, we shall mirror this new reality. Fix a namcap warning: since the system's architecture package is required, create symlinks to the shared content. (Then again, this wouldn't be needed if the content was splitted as done in other distros, allowing to use the same content where needed). Signed-off-by: Alexandre Demers <alexandre.f.demers@gmail.com>
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD17
2 files changed, 16 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 001a7325a861..f7c5182d8047 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = lib32-dav1d
pkgdesc = AV1 cross-platform decoder focused on speed and correctness (32 bit)
pkgver = 0.7.1
- pkgrel = 1
+ pkgrel = 2
url = https://code.videolan.org/videolan/dav1d/
arch = x86_64
license = BSD
diff --git a/PKGBUILD b/PKGBUILD
index 5b7ff12f22f3..f47c8b2b2f15 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgbasename=dav1d
pkgname=lib32-$_pkgbasename
pkgver=0.7.1
-pkgrel=1
+pkgrel=2
pkgdesc='AV1 cross-platform decoder focused on speed and correctness (32 bit)'
url='https://code.videolan.org/videolan/dav1d/'
arch=('x86_64')
@@ -63,5 +63,18 @@ package() {
cd ${_pkgbasename}-${pkgver}
DESTDIR="${pkgdir}" ninja -C build install
- rm -r "$pkgdir"/usr/{include,bin}
+
+ # Keep files in bin since this is not a library only package.
+ # Use the same naming scheme as proposed in Arch's wiki: https://wiki.archlinux.org/index.php/32-bit_package_guidelines
+ # which is "--program-suffix="-32" with Autoconf
+ for i in "${pkgdir}/usr/bin/"*; do
+ mv "$i" "$i"-32
+ done
+
+ rm -r "$pkgdir"/usr/include
+
+ mkdir -p "${pkgdir}/usr/share/doc/${pkgname}/"
+ mkdir -p "${pkgdir}/usr/share/licenses/${pkgname}/"
+ ln -s "/usr/share/doc/${_pkgbasename}/"README.md "${pkgdir}/usr/share/doc/${pkgname}/"
+ ln -s "/usr/share/licenses/${_pkgbasename}/"COPYING "${pkgdir}/usr/share/licenses/${pkgname}/"
}