summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandre Demers2020-05-09 00:52:46 -0400
committerAlexandre Demers2020-05-09 00:52:46 -0400
commita0c6af7c3ee0e19d9ba6ad597689de9d22d6f000 (patch)
tree17e5b432de6c7c47e08e132dd938e9393ded960b
parent11910bdff6bfec61ece134863b8f24df17a075dc (diff)
downloadaur-a0c6af7c3ee0e19d9ba6ad597689de9d22d6f000.tar.gz
Rebuild against latest libplacebo and fix env variables for compilation
Meson doesn't properly use LDFLAGS for now, so revert back to using env variables for now. Remove undeed dependencies. Disable tests, we assume that if the tests are fine under the system arch package, it should be fine under 32 bit also. Signed-off-by: Alexandre Demers <alexandre.f.demers@gmail.com>
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD24
2 files changed, 17 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c070afd6e5b1..b4a309373914 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,17 @@
pkgbase = lib32-dav1d
pkgdesc = AV1 cross-platform decoder focused on speed and correctness (32 bit)
pkgver = 0.6.0
- pkgrel = 1
+ pkgrel = 2
url = https://code.videolan.org/videolan/dav1d/
arch = x86_64
license = BSD
makedepends = meson
- makedepends = meson-cross-x86-linux-gnu
makedepends = ninja
makedepends = nasm
makedepends = doxygen
makedepends = vulkan-headers
depends = dav1d
depends = lib32-glibc
- depends = lib32-sdl2
- depends = lib32-libplacebo
depends = lib32-vulkan-icd-loader
provides = libdav1d.so
source = https://downloads.videolan.org/pub/videolan/dav1d/0.6.0/dav1d-0.6.0.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
index 212eb857994f..8f3b150de5f6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgbasename=dav1d
pkgname=lib32-$_pkgbasename
pkgver=0.6.0
-pkgrel=1
+pkgrel=2
pkgdesc='AV1 cross-platform decoder focused on speed and correctness (32 bit)'
url='https://code.videolan.org/videolan/dav1d/'
arch=('x86_64')
@@ -11,13 +11,11 @@ license=('BSD')
depends=(
"$_pkgbasename"
'lib32-glibc'
- 'lib32-sdl2'
- 'lib32-libplacebo'
'lib32-vulkan-icd-loader'
)
makedepends=(
'meson'
- 'meson-cross-x86-linux-gnu'
+# 'meson-cross-x86-linux-gnu'
'ninja'
'nasm'
'doxygen'
@@ -36,22 +34,32 @@ prepare() {
}
build() {
+ export CC="gcc -m32"
+ export CXX="g++ -m32"
+ export PKG_CONFIG_PATH="/usr/lib32/pkgconfig"
+ export CFLAGS+=" ${CPPFLAGS}"
+ export CXXFLAGS+=" ${CPPFLAGS} -I/usr/include/glslang"
+
cd ${_pkgbasename}-${pkgver}
arch-meson build \
- --cross-file x86-linux-gnu \
- --libdir=/usr/lib32
+ --prefix=/usr \
+ --libdir=lib32 \
+ -D enable_tests=false
+
+# Options disabled
+# --cross-file x86-linux-gnu \ ## Meson doesn't use the system's LDFLAGS with cross-file yet...
ninja -C build
}
check() {
cd ${_pkgbasename}-${pkgver}/build
- meson test
+# meson test
}
package() {
cd ${_pkgbasename}-${pkgver}
DESTDIR="${pkgdir}" ninja -C build install
- rm -rf "$pkgdir"/usr/{include,share,bin}
+ rm -r "$pkgdir"/usr/{include,bin}
}