summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandre Demers2019-08-16 02:53:02 -0400
committerAlexandre Demers2019-08-16 02:53:02 -0400
commitc613e4900a91a8093e4bde1b48c11b9572268b17 (patch)
tree38f31b5cf64492a54644bd6dd3d3ab871128ffbd
parent6f810300bdf0248796aa5b8c22edaa9a32b36903 (diff)
downloadaur-c613e4900a91a8093e4bde1b48c11b9572268b17.tar.gz
Force CC and CXX to solve a compilation problem
Even when using CFLAGS and CXXFLAGS with -m32, the cpu family and cpu are not set correctly when arch-meson is called. Forcing CC and CXX solves the problem. Signed-off-by: Alexandre Demers <alexandre.f.demers@gmail.com>
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 4 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d16b5b40e116..c0149e463ace 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = lib32-dav1d
pkgdesc = AV1 cross-platform decoder focused on speed and correctness (32 bit)
pkgver = 0.4.0
- pkgrel = 1
+ pkgrel = 2
url = https://code.videolan.org/videolan/dav1d/
arch = x86_64
license = BSD
diff --git a/PKGBUILD b/PKGBUILD
index 4ac01f7005ee..1f1ef93127fd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgbasename=dav1d
pkgname=lib32-$_pkgbasename
pkgver=0.4.0
-pkgrel=1
+pkgrel=2
pkgdesc='AV1 cross-platform decoder focused on speed and correctness (32 bit)'
url='https://code.videolan.org/videolan/dav1d/'
arch=('x86_64')
@@ -35,8 +35,8 @@ prepare() {
}
build() {
- export CFLAGS="-m32"
- export CXXFLAGS="-m32"
+ export CC="gcc -m32"
+ export CXX="g++ -m32"
export PKG_CONFIG_PATH="/usr/lib32/pkgconfig"
cd ${_pkgbasename}-${pkgver}