summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent Grande2020-10-08 19:03:29 -0400
committerVincent Grande2020-10-08 19:03:29 -0400
commitced57f532a6227a2ec57310e653ea380c0564a5e (patch)
tree00f0e65f1ebf9e0ec5b3cb180a69b85a6dfe1c28
downloadaur-lib32-dbus-nosystemd-git.tar.gz
initial upload
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD99
-rw-r--r--no-fatal-warnings.diff13
3 files changed, 137 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..929a63275a57
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = lib32-dbus-nosystemd-git
+ pkgdesc = Freedesktop.org message bus system (32-bit)
+ pkgver = 1.12.20
+ pkgrel = 1
+ url = https://gitlab.freedesktop.org/dbus/dbus
+ arch = x86_64
+ license = GPL
+ license = custom
+ makedepends = lib32-gcc-libs
+ makedepends = lib32-expat
+ makedepends = git
+ makedepends = autoconf-archive
+ depends = dbus
+ provides = lib32-libdbus
+ provides = lib32-dbus
+ conflicts = lib32-libdbus
+ conflicts = lib32-dbus
+ replaces = lib32-libdbus
+ source = git+https://gitlab.freedesktop.org/dbus/dbus.git
+ source = no-fatal-warnings.diff
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = lib32-dbus-nosystemd-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ca97baf1fd15
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,99 @@
+# Maintainer : Vincent Grande <shoober420@gmail.com>
+# Contributor : Eric Vidal <eric@obarun.org>
+# Contributor : Jean-Michel T.Dydak <jean-michel@obarun.org>
+# Contributor : Ionut Biru <ibiru@archlinux.org>
+
+pkgname=lib32-dbus-nosystemd-git
+pkgbasename=dbus
+pkgver=1.12.20
+pkgrel=1
+arch=('x86_64')
+pkgdesc="Freedesktop.org message bus system (32-bit)"
+license=(GPL custom)
+url="https://gitlab.freedesktop.org/dbus/dbus"
+
+source=("git+https://gitlab.freedesktop.org/dbus/dbus.git"
+ 'no-fatal-warnings.diff')
+
+provides=(
+ 'lib32-libdbus' 'lib32-dbus')
+
+conflicts=(
+ 'lib32-libdbus' 'lib32-dbus')
+
+replaces=(
+ 'lib32-libdbus')
+
+depends=(
+ 'dbus')
+
+makedepends=(
+ 'lib32-gcc-libs'
+ 'lib32-expat'
+ 'git'
+ 'autoconf-archive')
+
+pkgver() {
+ cd "${pkgbasename}"
+ git describe --tags | sed 's/^dbus-//;s/-/+/g'
+}
+
+prepare() {
+
+ cd "${pkgbasename}"
+
+# Allow us to enable checks without them being fatal
+ patch -Np1 -i ../no-fatal-warnings.diff
+
+ NOCONFIGURE=1 ./autogen.sh
+}
+
+build() {
+ export CC="gcc -m32"
+ export CXX="g++ -m32"
+ export PKG_CONFIG="i686-pc-linux-gnu-pkg-config"
+
+ cd "${pkgbasename}"
+
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --libdir=/usr/lib32 \
+ --libexecdir=/usr/lib/dbus-1.0 \
+ runstatedir=/run \
+ --with-system-pid-file=/run/dbus/pid \
+ --with-system-socket=/run/dbus/system_bus_socket \
+ --with-dbus-session-bus-listen-address=unix:runtime=yes \
+ --with-dbus-session-bus-connect-address=autolaunch: \
+ --with-dbus-user=dbus \
+ --with-console-auth-dir=/run/console/ \
+ --enable-inotify \
+ --disable-static \
+ --disable-verbose-mode \
+ --disable-asserts \
+ --disable-systemd \
+ --without-systemdsystemunitdir \
+ --disable-user-session \
+ --without-x \
+ --disable-x11-autolaunch \
+ --disable-checks
+ make
+}
+
+#check() {
+# make -C "${pkgbasename}" check
+#}
+
+package() {
+ DESTDIR="${pkgdir}" make -C "${pkgbasename}" install
+
+ rm -r "${pkgdir}"/usr/{bin,include,lib,share}
+ rm -r "${pkgdir}"/{etc,var}
+
+ install -d "${pkgdir}/usr/share/licenses"
+ ln -s "${pkgbasename}" "${pkgdir}/usr/share/licenses/${pkgname}"
+}
+
+sha256sums=('SKIP'
+ 'SKIP')
diff --git a/no-fatal-warnings.diff b/no-fatal-warnings.diff
new file mode 100644
index 000000000000..459da9047a50
--- /dev/null
+++ b/no-fatal-warnings.diff
@@ -0,0 +1,13 @@
+diff --git i/dbus/dbus-internals.c w/dbus/dbus-internals.c
+index 267aef97..b1064e85 100644
+--- i/dbus/dbus-internals.c
++++ w/dbus/dbus-internals.c
+@@ -185,7 +185,7 @@ const char *_dbus_no_memory_message = "Not enough memory";
+
+ static dbus_bool_t warn_initted = FALSE;
+ static dbus_bool_t fatal_warnings = FALSE;
+-static dbus_bool_t fatal_warnings_on_check_failed = TRUE;
++static dbus_bool_t fatal_warnings_on_check_failed = FALSE;
+
+ static void
+ init_warnings(void)