summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavorin Učakar2020-06-11 23:32:17 +0200
committerDavorin Učakar2020-06-11 23:33:19 +0200
commitfb8a4a731e66e4fbc98b46f8667f057ef4605cf2 (patch)
treef93cbc42b6d8e1c01f1be47a9b9382feba45bb09
parenta0dabb1b6c4941721b68dc8e829d7769af0a0c7f (diff)
downloadaur-lib32-freeimage.tar.gz
Update to 3.18.0
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD22
-rw-r--r--gcc5.patch70
3 files changed, 11 insertions, 93 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e3caf355d90c..101b9ea75827 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,7 @@
-# Generated by mksrcinfo v8
-# Sat May 28 07:51:33 UTC 2016
pkgbase = lib32-freeimage
pkgdesc = Library project for developers who would like to support popular graphics image formats
- pkgver = 3.17.0
- pkgrel = 3
+ pkgver = 3.18.0
+ pkgrel = 1
url = http://freeimage.sourceforge.net
arch = x86_64
license = GPL
@@ -11,10 +9,8 @@ pkgbase = lib32-freeimage
makedepends = gcc-multilib
depends = freeimage
depends = lib32-gcc-libs
- source = http://downloads.sourceforge.net/project/freeimage/Source%20Distribution/3.17.0/FreeImage3170.zip
- source = gcc5.patch
- sha1sums = 6752c83798c2f81dee71a2e8bb11657068672669
- sha1sums = cd4342306e55b86947ae5872495abf675edefd73
+ source = http://downloads.sourceforge.net/project/freeimage/Source%20Distribution/3.18.0/FreeImage3180.zip
+ sha256sums = f41379682f9ada94ea7b34fe86bf9ee00935a3147be41b6569c9605a53e438fd
pkgname = lib32-freeimage
diff --git a/PKGBUILD b/PKGBUILD
index b6f39dd8fa4b..99fa124b4753 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,24 +7,16 @@
# Maintainer: Davorin Učakar <davorin.ucakar@gmail.com>
pkgname=lib32-freeimage
-pkgver=3.17.0
-pkgrel=3
+pkgver=3.18.0
+pkgrel=1
pkgdesc="Library project for developers who would like to support popular graphics image formats"
arch=('x86_64')
license=('GPL' 'custom:FIPL')
url="http://freeimage.sourceforge.net"
depends=('freeimage' 'lib32-gcc-libs')
makedepends=('gcc-multilib')
-source=("http://downloads.sourceforge.net/project/freeimage/Source%20Distribution/${pkgver}/FreeImage${pkgver//./}.zip"
- 'gcc5.patch')
-sha1sums=('6752c83798c2f81dee71a2e8bb11657068672669'
- 'cd4342306e55b86947ae5872495abf675edefd73')
-
-prepare()
-{
- cd FreeImage
- patch -p1 -i ../gcc5.patch
-}
+source=("http://downloads.sourceforge.net/project/freeimage/Source%20Distribution/${pkgver}/FreeImage${pkgver//./}.zip")
+sha256sums=('f41379682f9ada94ea7b34fe86bf9ee00935a3147be41b6569c9605a53e438fd')
build()
{
@@ -33,12 +25,12 @@ build()
export CFLAGS="${CFLAGS/-march=x86-64} -O3 -fPIC -fvisibility=hidden -DNO_LCMS"
export CXXFLAGS="${CXXFLAGS/-march=x86-64} -O3 -fPIC -fvisibility=hidden"
- cd FreeImage
+ cd FreeImage
make
- make -f Makefile.fip
+ make -f Makefile.fip
}
-package()
+package()
{
cd FreeImage
make DESTDIR=${pkgdir} install || true
diff --git a/gcc5.patch b/gcc5.patch
deleted file mode 100644
index d066a0253d9f..000000000000
--- a/gcc5.patch
+++ /dev/null
@@ -1,70 +0,0 @@
-diff -Naur FreeImage.orig/Source/LibWebP/src/dsp/dsp.upsampling_mips_dsp_r2.c FreeImage/Source/LibWebP/src/dsp/dsp.upsampling_mips_dsp_r2.c
---- FreeImage.orig/Source/LibWebP/src/dsp/dsp.upsampling_mips_dsp_r2.c 2015-06-28 16:49:39.320546812 +0200
-+++ FreeImage/Source/LibWebP/src/dsp/dsp.upsampling_mips_dsp_r2.c 2015-06-28 16:50:14.189740757 +0200
-@@ -21,33 +21,6 @@
-
- #if !defined(WEBP_YUV_USE_TABLE)
-
--#define YUV_TO_RGB(Y, U, V, R, G, B) do { \
-- const int t1 = kYScale * Y; \
-- const int t2 = kVToG * V; \
-- R = kVToR * V; \
-- G = kUToG * U; \
-- B = kUToB * U; \
-- R = t1 + R; \
-- G = t1 - G; \
-- B = t1 + B; \
-- R = R + kRCst; \
-- G = G - t2 + kGCst; \
-- B = B + kBCst; \
-- __asm__ volatile ( \
-- "shll_s.w %["#R"], %["#R"], 9 \n\t" \
-- "shll_s.w %["#G"], %["#G"], 9 \n\t" \
-- "shll_s.w %["#B"], %["#B"], 9 \n\t" \
-- "precrqu_s.qb.ph %["#R"], %["#R"], $zero \n\t" \
-- "precrqu_s.qb.ph %["#G"], %["#G"], $zero \n\t" \
-- "precrqu_s.qb.ph %["#B"], %["#B"], $zero \n\t" \
-- "srl %["#R"], %["#R"], 24 \n\t" \
-- "srl %["#G"], %["#G"], 24 \n\t" \
-- "srl %["#B"], %["#B"], 24 \n\t" \
-- : [R]"+r"(R), [G]"+r"(G), [B]"+r"(B) \
-- : \
-- ); \
-- } while (0)
--
- static WEBP_INLINE void YuvToRgb(int y, int u, int v, uint8_t* const rgb) {
- int r, g, b;
- YUV_TO_RGB(y, u, v, r, g, b);
-diff -Naur FreeImage.orig/Source/LibWebP/src/dsp/dsp.yuv_mips_dsp_r2.c FreeImage/Source/LibWebP/src/dsp/dsp.yuv_mips_dsp_r2.c
---- FreeImage.orig/Source/LibWebP/src/dsp/dsp.yuv_mips_dsp_r2.c 2015-06-28 16:49:39.320546812 +0200
-+++ FreeImage/Source/LibWebP/src/dsp/dsp.yuv_mips_dsp_r2.c 2015-06-28 16:50:59.357137570 +0200
-@@ -35,29 +35,6 @@
- "addu %[temp2], %[temp2], %[temp3] \n\t" \
- "addu %[temp4], %[temp4], %[t_con_8] \n\t" \
-
--#define ROW_FUNC_PART_2(R, G, B, K) \
-- "addu %[temp5], %[temp0], %[temp1] \n\t" \
-- "subu %[temp6], %[temp0], %[temp2] \n\t" \
-- "addu %[temp7], %[temp0], %[temp4] \n\t" \
--".if "#K" \n\t" \
-- "lbu %[temp0], 1(%[y]) \n\t" \
--".endif \n\t" \
-- "shll_s.w %[temp5], %[temp5], 9 \n\t" \
-- "shll_s.w %[temp6], %[temp6], 9 \n\t" \
--".if "#K" \n\t" \
-- "mul %[temp0], %[t_con_5], %[temp0] \n\t" \
--".endif \n\t" \
-- "shll_s.w %[temp7], %[temp7], 9 \n\t" \
-- "precrqu_s.qb.ph %[temp5], %[temp5], $zero \n\t" \
-- "precrqu_s.qb.ph %[temp6], %[temp6], $zero \n\t" \
-- "precrqu_s.qb.ph %[temp7], %[temp7], $zero \n\t" \
-- "srl %[temp5], %[temp5], 24 \n\t" \
-- "srl %[temp6], %[temp6], 24 \n\t" \
-- "srl %[temp7], %[temp7], 24 \n\t" \
-- "sb %[temp5], "#R"(%[dst]) \n\t" \
-- "sb %[temp6], "#G"(%[dst]) \n\t" \
-- "sb %[temp7], "#B"(%[dst]) \n\t" \
--
- #define ASM_CLOBBER_LIST() \
- : [temp0]"=&r"(temp0), [temp1]"=&r"(temp1), [temp2]"=&r"(temp2), \
- [temp3]"=&r"(temp3), [temp4]"=&r"(temp4), [temp5]"=&r"(temp5), \