summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandre Demers2023-09-17 14:31:20 -0400
committerAlexandre Demers2023-09-17 14:31:20 -0400
commit0afd6d739b950f81bfa1abe33738c01a12c6f108 (patch)
tree54cb6e20c4bf69e848bd7b9801119bbda71de4da
parent9633a9c77ea4c2ba8c04278fa715aa1350c5379f (diff)
downloadaur-lib32-glslang.tar.gz
Upgrade to 13.0.0
And remove patch 3283 Signed-off-by: Alexandre Demers <alexandre.f.demers@gmail.com>
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD32
2 files changed, 19 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 440ebe3ceb6c..bbcfb7850972 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lib32-glslang
pkgdesc = OpenGL and OpenGL ES shader front end and validator (32bit)
- pkgver = 12.3.1
+ pkgver = 13.0.0
pkgrel = 1
url = https://github.com/KhronosGroup/glslang
arch = x86_64
@@ -10,14 +10,12 @@ pkgbase = lib32-glslang
makedepends = git
makedepends = lib32-spirv-tools
makedepends = spirv-headers
- depends = glslang>=12.3.1
+ depends = glslang>=13.0.0
depends = lib32-glibc
depends = lib32-gcc-libs
depends = python
options = staticlibs
- source = lib32-glslang-12.3.1.tar.gz::https://github.com/KhronosGroup/glslang/archive/12.3.1.tar.gz
- source = https://patch-diff.githubusercontent.com/raw/KhronosGroup/glslang/pull/3283.patch
- sha256sums = a57836a583b3044087ac51bb0d5d2d803ff84591d55f89087fc29ace42a8b9a8
- sha256sums = 267b65a5205315e980f077f5fa401223003fdb5a38162e6ae697d38f68115137
+ source = lib32-glslang-13.0.0.tar.gz::https://github.com/KhronosGroup/glslang/archive/13.0.0.tar.gz
+ sha256sums = bcda732434f829aa74414ea0e06d329ec8ac28637c38a0de45e17c8fd25a4715
pkgname = lib32-glslang
diff --git a/PKGBUILD b/PKGBUILD
index f528ae4a138a..7fa5b3cdec4e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,46 +9,44 @@
# resulting in us having to ship both. Instead, I recommend just waiting until
# upstream releases a compatible version of spirv-tools, then updating the
# spriv-tools system package and only then building glslang against that.
+
_setPrefix="/usr"
_setLibdir="lib32"
_setFullLibdir="${_setPrefix}/${_setLibdir}"
_pkgbasename=glslang
pkgname=lib32-$_pkgbasename
-pkgver=12.3.1
+pkgver=13.0.0
pkgrel=1
pkgdesc='OpenGL and OpenGL ES shader front end and validator (32bit)'
arch=('x86_64')
url='https://github.com/KhronosGroup/glslang'
license=('BSD')
depends=(
- "$_pkgbasename>=$pkgver"
- 'lib32-glibc'
- 'lib32-gcc-libs'
- 'python'
- )
+ "$_pkgbasename>=$pkgver"
+ 'lib32-glibc'
+ 'lib32-gcc-libs'
+ 'python'
+)
makedepends=(
- 'cmake'
- 'ninja'
- 'git'
- 'lib32-spirv-tools'
- 'spirv-headers'
- )
+ 'cmake'
+ 'ninja'
+ 'git'
+ 'lib32-spirv-tools'
+ 'spirv-headers'
+)
options=('staticlibs')
source=(
${pkgname}-${pkgver}.tar.gz::https://github.com/KhronosGroup/glslang/archive/${pkgver}.tar.gz
- https://patch-diff.githubusercontent.com/raw/KhronosGroup/glslang/pull/3283.patch
)
sha256sums=(
- 'a57836a583b3044087ac51bb0d5d2d803ff84591d55f89087fc29ace42a8b9a8'
- '267b65a5205315e980f077f5fa401223003fdb5a38162e6ae697d38f68115137'
- )
+ 'bcda732434f829aa74414ea0e06d329ec8ac28637c38a0de45e17c8fd25a4715'
+)
prepare() {
echo "Patching if needed"
cd ${_pkgbasename}-${pkgver}
- patch -Np1 -i "$srcdir"/3283.patch
}
build() {