summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBehnam Momeni2023-05-19 09:50:40 +0330
committerBehnam Momeni2023-05-19 09:50:40 +0330
commit315a7600cec95b751224dda874976dbc70388a70 (patch)
tree930791a94dabf765efca0f532a989d20e695e4af
parent9cf475829f3088248a2f33637311d76610c5dd60 (diff)
downloadaur-lib32-gobject-introspection.tar.gz
Upgrade dependencies to glib-2.76.2 and python-3.11
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD13
2 files changed, 15 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 38a379219ba5..fec049009a51 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Fri Apr 7 07:39:35 UTC 2023
+# Fri May 19 06:18:19 UTC 2023
pkgbase = lib32-gobject-introspection
pkgdesc = Introspection system for GObject-based libraries (32-bit)
pkgver = 1.76.1
- pkgrel = 1
+ pkgrel = 2
url = https://wiki.gnome.org/Projects/GObjectIntrospection
arch = x86_64
license = LGPL
@@ -14,12 +14,12 @@ pkgbase = lib32-gobject-introspection
makedepends = gtk-doc
makedepends = python-sphinx
makedepends = meson
- makedepends = lib32-glib2=2.76.1
+ makedepends = lib32-glib2=2.76.2
depends = python-mako
depends = python-markdown
- depends = lib32-python>=3.10
+ depends = lib32-python>=3.11
source = git+https://gitlab.gnome.org/GNOME/gobject-introspection.git#commit=1565805460c3fd65f8630debd0337ec0e33ee2e7
- source = git+https://gitlab.gnome.org/GNOME/glib.git#commit=180713772f4e7bcdddf2c793f2f34a498184ed15
+ source = git+https://gitlab.gnome.org/GNOME/glib.git#commit=41ae5b5632ce9f6b2b5613ec1912821f769166c2
source = x86-linux-gnu
sha512sums = SKIP
sha512sums = SKIP
@@ -28,9 +28,9 @@ pkgbase = lib32-gobject-introspection
pkgname = lib32-gobject-introspection
depends = python-mako
depends = python-markdown
- depends = lib32-python>=3.10
+ depends = lib32-python>=3.11
depends = gobject-introspection>=1.76.1
- depends = lib32-gobject-introspection-runtime=1.76.1-1
+ depends = lib32-gobject-introspection-runtime=1.76.1-2
pkgname = lib32-gobject-introspection-runtime
pkgdesc = Introspection system for GObject-based libraries (32-bit) (runtime library)
diff --git a/PKGBUILD b/PKGBUILD
index 769e90db1b63..f063ad991f58 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,14 +6,14 @@ pkgbase=lib32-gobject-introspection
_pkgbase=gobject-introspection
pkgname=(lib32-gobject-introspection lib32-gobject-introspection-runtime)
pkgver=1.76.1
-pkgrel=1
+pkgrel=2
pkgdesc="Introspection system for GObject-based libraries (32-bit)"
url="https://wiki.gnome.org/Projects/GObjectIntrospection"
arch=(x86_64)
license=(LGPL GPL)
-_glibver=2.76.1
-_glib_commit=180713772f4e7bcdddf2c793f2f34a498184ed15 # tags/2.76.1^0
-_pyver=3.10
+_glibver=2.76.2
+_glib_commit=41ae5b5632ce9f6b2b5613ec1912821f769166c2 # tags/2.76.2^0
+_pyver=3.11
depends=("python-mako" "python-markdown" "lib32-python>=${_pyver}")
makedepends=(bison lib32-cairo git gtk-doc python-sphinx meson "lib32-glib2=$_glibver")
_commit=1565805460c3fd65f8630debd0337ec0e33ee2e7 # tags/1.76.1^0
@@ -67,7 +67,10 @@ _pick() {
}
package_lib32-gobject-introspection() {
- depends+=("gobject-introspection>=$pkgver" "lib32-gobject-introspection-runtime=$pkgver-$pkgrel")
+ depends+=(
+ "gobject-introspection>=$pkgver"
+ "lib32-gobject-introspection-runtime=$pkgver-$pkgrel"
+ )
export CC="gcc -m32"
export CXX="g++ -m32"