summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Teibes2015-07-12 00:00:23 +0200
committerCarsten Teibes2015-07-12 00:00:23 +0200
commitc057454b80ea4471fd09b9618b99a91bb3678ab0 (patch)
tree0245ad3b39c7f341ef78a6cf407c1589f6a41754
downloadaur-lib32-gtk-engine-murrine.tar.gz
[add] lib32-gtk-engine-murrine 0.98.2
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD32
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..980e9ee7f965
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = lib32-gtk-engine-murrine
+ pkgdesc = GTK2 engine to make your desktop look like the art glass works done by Venicians glass blowers (32 bit)
+ pkgver = 0.98.2
+ pkgrel = 2
+ url = http://cimitan.com/murrine/project/murrine
+ arch = x86_64
+ license = LGPL3
+ makedepends = gcc-multilib
+ makedepends = intltool
+ depends = lib32-gtk2
+ depends = gtk-engine-murrine
+ source = http://ftp.gnome.org/pub/GNOME/sources/murrine/0.98/murrine-0.98.2.tar.xz
+ sha256sums = e9c68ae001b9130d0f9d1b311e8121a94e5c134b82553ba03971088e57d12c89
+
+pkgname = lib32-gtk-engine-murrine
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7c30dfb2ff4c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
+# Contributor: SpepS <dreamspepser at yahoo dot it>
+# Contributor: Jonathan Conder <jonno dot conder at gmail dot com>
+
+pkgname=lib32-gtk-engine-murrine
+pkgver=0.98.2
+pkgrel=2
+pkgdesc="GTK2 engine to make your desktop look like the art glass works done by Venicians glass blowers (32 bit)"
+arch=('x86_64')
+url="http://cimitan.com/murrine/project/murrine"
+license=('LGPL3')
+depends=('lib32-gtk2' "${pkgname#*-}")
+makedepends=('gcc-multilib' 'intltool')
+source=("http://ftp.gnome.org/pub/GNOME/sources/murrine/0.98/murrine-$pkgver.tar.xz")
+sha256sums=('e9c68ae001b9130d0f9d1b311e8121a94e5c134b82553ba03971088e57d12c89')
+
+build() {
+ cd murrine-$pkgver
+
+ export CC='gcc -m32'
+ export PKG_CONFIG_PATH='/usr/lib32/pkgconfig'
+
+ ./configure --prefix=/usr --libdir=/usr/lib32 --enable-animation --enable-animationrtl
+ make
+}
+
+package() {
+ make -C murrine-$pkgver DESTDIR="$pkgdir" install
+
+ # cleanup
+ rm -rf "$pkgdir"/usr/share
+}