summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLone_Wolf2022-04-30 20:10:50 +0200
committerLone_Wolf2022-04-30 20:10:50 +0200
commit1ab512db86518a6359c40f6e4519ff8eb610b35b (patch)
treed4d5dc628777c60a0763e9141fd5b49b08409497
parentc163f69a5fea206b9be23ebeca5589f9a023043f (diff)
downloadaur-1ab512db86518a6359c40f6e4519ff8eb610b35b.tar.gz
added patch to workaround build failure coroutines.h
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD13
-rw-r--r--workaround--LLVM15-FTBFS-no-more-Coroutines.h.patch15
3 files changed, 29 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8a4962bf1d1e..3afea2f9eb80 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lib32-mesa-minimal-git
pkgdesc = an open-source implementation of the OpenGL specification, git version
- pkgver = 22.0.0_devel.147902.c50bdacbda6
+ pkgver = 22.2.0_devel.153079.6ba55b40334
pkgrel = 1
url = https://www.mesa3d.org
arch = x86_64
@@ -52,11 +52,14 @@ pkgbase = lib32-mesa-minimal-git
source = mesa::git+https://gitlab.freedesktop.org/mesa/mesa.git
source = LICENSE
source = llvm32.native
+ source = workaround--LLVM15-FTBFS-no-more-Coroutines.h.patch
md5sums = SKIP
md5sums = 5c65a0fe315dd347e09b1f2826a1df5a
md5sums = 6b4a19068a323d7f90a3d3cd315ed1f9
+ md5sums = a4e1e8a8a90b6434b80d8ec859747e0c
sha512sums = SKIP
sha512sums = 25da77914dded10c1f432ebcbf29941124138824ceecaf1367b3deedafaecabc082d463abcfa3d15abff59f177491472b505bcb5ba0c4a51bb6b93b4721a23c2
sha512sums = c7dbb390ebde291c517a854fcbe5166c24e95206f768cc9458ca896b2253aabd6df12a7becf831998721b2d622d0c02afdd8d519e77dea8e1d6807b35f0166fe
+ sha512sums = ee96c9c3c29cfd7bffc1ee72fecf6bdd9a4ac7245afa11e7b28432e8695fc9d16d241cb8330029e5460cc54898258b87bc73d99fc1bf9743ce9bb718a85f5806
pkgname = lib32-mesa-minimal-git
diff --git a/PKGBUILD b/PKGBUILD
index 5e46fd636f23..d99a1b1ebea6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,7 +12,7 @@
pkgname=lib32-mesa-minimal-git
pkgdesc="an open-source implementation of the OpenGL specification, git version"
-pkgver=22.0.0_devel.147902.c50bdacbda6
+pkgver=22.2.0_devel.153079.6ba55b40334
pkgrel=1
arch=('x86_64')
makedepends=('python-mako' 'lib32-libxml2' 'lib32-libx11' 'xorgproto'
@@ -28,14 +28,17 @@ license=('custom')
source=('mesa::git+https://gitlab.freedesktop.org/mesa/mesa.git'
'LICENSE'
'llvm32.native'
+ 'workaround--LLVM15-FTBFS-no-more-Coroutines.h.patch'
)
md5sums=('SKIP'
'5c65a0fe315dd347e09b1f2826a1df5a'
- '6b4a19068a323d7f90a3d3cd315ed1f9')
+ '6b4a19068a323d7f90a3d3cd315ed1f9'
+ 'a4e1e8a8a90b6434b80d8ec859747e0c')
sha512sums=('SKIP'
'25da77914dded10c1f432ebcbf29941124138824ceecaf1367b3deedafaecabc082d463abcfa3d15abff59f177491472b505bcb5ba0c4a51bb6b93b4721a23c2'
- 'c7dbb390ebde291c517a854fcbe5166c24e95206f768cc9458ca896b2253aabd6df12a7becf831998721b2d622d0c02afdd8d519e77dea8e1d6807b35f0166fe')
+ 'c7dbb390ebde291c517a854fcbe5166c24e95206f768cc9458ca896b2253aabd6df12a7becf831998721b2d622d0c02afdd8d519e77dea8e1d6807b35f0166fe'
+ 'ee96c9c3c29cfd7bffc1ee72fecf6bdd9a4ac7245afa11e7b28432e8695fc9d16d241cb8330029e5460cc54898258b87bc73d99fc1bf9743ce9bb718a85f5806')
# NINJAFLAGS is an env var used to pass commandline options to ninja
# NOTE: It's your responbility to validate the value of $NINJAFLAGS. If unsure, don't set it.
@@ -52,6 +55,10 @@ prepare() {
if [ -d _build ]; then
rm -rf _build
fi
+
+ # see https://gitlab.freedesktop.org/mesa/mesa/-/issues/6359
+ patch --directory="mesa" --forward --strip=1 --input="${srcdir}/workaround--LLVM15-FTBFS-no-more-Coroutines.h.patch"
+
}
build () {
diff --git a/workaround--LLVM15-FTBFS-no-more-Coroutines.h.patch b/workaround--LLVM15-FTBFS-no-more-Coroutines.h.patch
new file mode 100644
index 000000000000..597eff7bc707
--- /dev/null
+++ b/workaround--LLVM15-FTBFS-no-more-Coroutines.h.patch
@@ -0,0 +1,15 @@
+---
+ src/gallium/auxiliary/gallivm/lp_bld.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+--- a/src/gallium/auxiliary/gallivm/lp_bld.h
++++ b/src/gallium/auxiliary/gallivm/lp_bld.h
+@@ -81,7 +81,7 @@
+ #define LLVMInsertBasicBlock ILLEGAL_LLVM_FUNCTION
+ #define LLVMCreateBuilder ILLEGAL_LLVM_FUNCTION
+
+-#if LLVM_VERSION_MAJOR >= 8
++#if LLVM_VERSION_MAJOR >= 8 && LLVM_VERSION_MAJOR < 15
+ #define GALLIVM_HAVE_CORO 1
+ #else
+ #define GALLIVM_HAVE_CORO 0