summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLone_Wolf2022-08-17 19:59:28 +0200
committerLone_Wolf2022-08-17 19:59:28 +0200
commitfa29b3460ee779eac2b08271e6169b16490c6e4e (patch)
treef3edaab36cc014e358f9b0251298822549469ead
parentb62880388081eb0504976b9a3bcbf2b84cb4479e (diff)
downloadaur-fa29b3460ee779eac2b08271e6169b16490c6e4e.tar.gz
force c++17 to fix build with latest llvm 16
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 552d2570f982..6e3767874025 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lib32-mesa-minimal-git
pkgdesc = an open-source implementation of the OpenGL specification, git version
- pkgver = 22.2.0_devel.153476.b4957cdfcae
+ pkgver = 22.3.0_devel.158199.d7e6174c2bd4
pkgrel = 1
url = https://www.mesa3d.org
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index eac2c6487594..235fd0bbf62f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,7 +12,7 @@
pkgname=lib32-mesa-minimal-git
pkgdesc="an open-source implementation of the OpenGL specification, git version"
-pkgver=22.2.0_devel.153476.b4957cdfcae
+pkgver=22.3.0_devel.158199.d7e6174c2bd4
pkgrel=1
arch=('x86_64')
makedepends=('python-mako' 'lib32-libxml2' 'lib32-libx11' 'xorgproto'
@@ -60,12 +60,18 @@ build () {
export CC="gcc -m32"
export CXX="g++ -m32"
export PKG_CONFIG=/usr/bin/i686-pc-linux-gnu-pkg-config
+
+# llvm 16 switchted to c++17 by default in https://github.com/llvm/llvm-project/commit/b4e9977fc18405d4a11cbaf1975bcadbf75920b8
+# use cpp_std=c++17 to force that version
+# can be removed once https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/17966 is merged to master
+
meson setup mesa _build \
--native-file llvm32.native \
-D b_ndebug=true \
-D b_lto=true \
-D buildtype=plain \
+ -D cpp_std=c++17 \
--wrap-mode=nofallback \
-D prefix=/usr \
-D sysconfdir=/etc \