summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlibele2022-12-21 23:49:10 -0600
committerlibele2022-12-21 23:49:10 -0600
commit43cf4f3658339a2989b8f6acae07ef7e8ad71a40 (patch)
tree0f744f6844d39a430aa86166a151fee33942477f
parentcc7dd86d6d8f76e236ed743d5c247d824b8a76d8 (diff)
downloadaur-lib32-python2.tar.gz
add latest gentoo patches tarball, depend on openssl-1.1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD21
-rw-r--r--py2-ize-the-CJK-codec-test.patch46
3 files changed, 18 insertions, 61 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8c177c6ade41..8ca55a86399d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = lib32-python2
pkgdesc = A high-level scripting language (32 bit)
pkgver = 2.7.18
- pkgrel = 3
+ pkgrel = 4
url = https://www.python.org/
arch = x86_64
license = PSF
@@ -11,24 +11,22 @@ pkgbase = lib32-python2
depends = lib32-expat
depends = lib32-gdbm
depends = lib32-libffi
- depends = lib32-openssl
+ depends = lib32-openssl-1.1
depends = lib32-sqlite
depends = lib32-zlib
depends = python2
optdepends = lib32-tk: for IDLE
conflicts = lib32-python<3
- noextract = python-gentoo-patches-2.7.18_p7.tar.xz
+ noextract = python-gentoo-patches-2.7.18_p16.tar.xz
options = !makeflags
source = https://www.python.org/ftp/python/2.7.18/Python-2.7.18.tar.xz
- source = https://dev.gentoo.org/~mgorny/dist/python/python-gentoo-patches-2.7.18_p7.tar.xz
+ source = https://dev.gentoo.org/~mgorny/dist/python/python-gentoo-patches-2.7.18_p16.tar.xz
source = mtime-workaround.patch
- source = py2-ize-the-CJK-codec-test.patch
source = python-config-32.patch
source = lib32-distutils-sysconfig.patch
sha512sums = a7bb62b51f48ff0b6df0b18f5b0312a523e3110f49c3237936bfe56ed0e26838c0274ff5401bda6fc21bf24337477ccac49e8026c5d651e4b4cafb5eb5086f6c
- sha512sums = a3cd34f38a717183d9a8d6b91817a6ac989fb8ae4275f35cba4be810813a4c9c45f4e72d16aee33904eddaee77c4719b516392d629d2c4627c840e4ecc6bc121
+ sha512sums = 810be590d0e06fab4b2165e6852ca49662f09dcd7e20b47a29f613ad7653252c8dfac3f0eb228d77c8a914efa7c08788b2fbd552a4b47504f5fd0ec17450c48f
sha512sums = 4e761cfd57791e8b72ecdf84c2e03875bf074311130eea5b8e97409fa304fa3468dbd359a511c4e9978e686e662c58054b4174d3e73f845fa9ded2e83a3a8076
- sha512sums = 67fb8116825f646cbe0f12d9ffb68c2e2006e98721c80c674738315160c0dfdb5f200b8d3229f85dbac2510ba436b0f701e44542ce4494cdd191cd1b8ca0bf0f
sha512sums = 68643c7632bd5a8c17fd095589ae97b137313852f75904cc1065d424b731702c9ef5bed4ff711bbde9ce1fe869eac3a32de0743e56070faca66ab63e227d6469
sha512sums = 6a661446a022f3c2e7f0273310c90cd6325efa3aaa0cad833b8fc63f89afd3f70a07795fe46b160a227f5094af25e03e19d094996d49f76f4ecb867b92edff49
diff --git a/PKGBUILD b/PKGBUILD
index 254eeb44b9b5..07644f565909 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,31 +6,29 @@
_pkgbasename=python2
pkgname=lib32-$_pkgbasename
pkgver=2.7.18
-pkgrel=3
+pkgrel=4
_pybasever=2.7
pkgdesc="A high-level scripting language (32 bit)"
arch=('x86_64')
license=('PSF')
url="https://www.python.org/"
-depends=(lib32-{bzip2,db,expat,gdbm,libffi,openssl,sqlite,zlib} python2)
+depends=(lib32-{bzip2,db,expat,gdbm,libffi,openssl-1.1,sqlite,zlib} python2)
makedepends=('lib32-tk')
optdepends=('lib32-tk: for IDLE')
conflicts=('lib32-python<3')
-_gentoo_patches="python-gentoo-patches-${pkgver}_p7"
+_gentoo_patches="python-gentoo-patches-${pkgver}_p16"
noextract=("${_gentoo_patches}.tar.xz")
options=('!makeflags')
source=("https://www.python.org/ftp/python/${pkgver%rc?}/Python-${pkgver}.tar.xz"
"https://dev.gentoo.org/~mgorny/dist/python/${_gentoo_patches}.tar.xz"
'mtime-workaround.patch'
- 'py2-ize-the-CJK-codec-test.patch'
'python-config-32.patch'
'lib32-distutils-sysconfig.patch')
sha512sums=('a7bb62b51f48ff0b6df0b18f5b0312a523e3110f49c3237936bfe56ed0e26838c0274ff5401bda6fc21bf24337477ccac49e8026c5d651e4b4cafb5eb5086f6c'
- 'a3cd34f38a717183d9a8d6b91817a6ac989fb8ae4275f35cba4be810813a4c9c45f4e72d16aee33904eddaee77c4719b516392d629d2c4627c840e4ecc6bc121'
+ '810be590d0e06fab4b2165e6852ca49662f09dcd7e20b47a29f613ad7653252c8dfac3f0eb228d77c8a914efa7c08788b2fbd552a4b47504f5fd0ec17450c48f'
'4e761cfd57791e8b72ecdf84c2e03875bf074311130eea5b8e97409fa304fa3468dbd359a511c4e9978e686e662c58054b4174d3e73f845fa9ded2e83a3a8076'
- '67fb8116825f646cbe0f12d9ffb68c2e2006e98721c80c674738315160c0dfdb5f200b8d3229f85dbac2510ba436b0f701e44542ce4494cdd191cd1b8ca0bf0f'
'68643c7632bd5a8c17fd095589ae97b137313852f75904cc1065d424b731702c9ef5bed4ff711bbde9ce1fe869eac3a32de0743e56070faca66ab63e227d6469'
'6a661446a022f3c2e7f0273310c90cd6325efa3aaa0cad833b8fc63f89afd3f70a07795fe46b160a227f5094af25e03e19d094996d49f76f4ecb867b92edff49')
@@ -50,8 +48,13 @@ prepare() {
patch -p1 -i ../0005-bpo-41944-No-longer-call-eval-on-content-received-vi.patch #CVE-2020-27619
patch -p1 -i ../0006-bpo-40791-Make-compare_digest-more-constant-time.-GH.patch
patch -p1 -i ../0007-3.6-closes-bpo-42938-Replace-snprintf-with-Python-un.patch #CVE-2021-3177
- patch -p1 -i ../0024-3.6-bpo-42967-only-use-as-a-query-string-separator-G.patch #CVE-2021-23336
- patch -p1 -i ../py2-ize-the-CJK-codec-test.patch
+ patch -p1 -i ../0008-3.6-bpo-42967-only-use-as-a-query-string-separator-G.patch #CVE-2021-23336
+ patch -p1 -i ../0009-py2-ize-the-CJK-codec-test.patch
+ patch -p1 -i ../0017-bpo-46811-Make-test-suite-support-Expat-2.4.5-GH-314.patch
+
+ # Temporary workaround for FS#22322
+ # See http://bugs.python.org/issue10835 for upstream report
+ sed -i "/progname =/s/python/python${_pybasever}/" Python/pythonrun.c
# Enable built-in SQLite3 module to load extensions (fix FS#22122)
sed -i "/SQLITE_OMIT_LOAD_EXTENSION/d" setup.py
@@ -94,6 +97,8 @@ build() {
export LDFLAGS='-m32'
export PKG_CONFIG_PATH='/usr/lib32/pkgconfig'
+ CPPFLAGS+=" -I/usr/include/openssl-1.1"
+ LDFLAGS+=" -L/usr/lib32/openssl-1.1"
export OPT="${CFLAGS}"
./configure --prefix=/usr \
--enable-shared \
diff --git a/py2-ize-the-CJK-codec-test.patch b/py2-ize-the-CJK-codec-test.patch
deleted file mode 100644
index 72166c74b4b4..000000000000
--- a/py2-ize-the-CJK-codec-test.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-From ed1aa2f4738efe948242f252bcb0aa0b4314d2a2 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
-Date: Fri, 5 Mar 2021 10:34:50 +0100
-Subject: py2-ize the CJK codec test
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Signed-off-by: Michał Górny <mgorny@gentoo.org>
----
- Lib/test/multibytecodec_support.py | 5 +++--
- 1 file changed, 3 insertions(+), 2 deletions(-)
-
-diff --git a/Lib/test/multibytecodec_support.py b/Lib/test/multibytecodec_support.py
-index b7d7a3aba7..661ef9ee37 100644
---- a/Lib/test/multibytecodec_support.py
-+++ b/Lib/test/multibytecodec_support.py
-@@ -2,6 +2,7 @@
- # Common Unittest Routines for CJK codecs
- #
-
-+import binascii
- import codecs
- import os
- import re
-@@ -280,7 +281,7 @@ class TestBase_Mapping(unittest.TestCase):
-
- def _test_mapping_file_plain(self):
- def unichrs(s):
-- return ''.join(chr(int(x, 16)) for x in s.split('+'))
-+ return ''.join(unichr(int(x, 16)) for x in s.split('+'))
-
- urt_wa = {}
-
-@@ -294,7 +295,7 @@ class TestBase_Mapping(unittest.TestCase):
-
- if data[0][:2] != '0x':
- self.fail("Invalid line: {line!r}".format(line=line))
-- csetch = bytes.fromhex(data[0][2:])
-+ csetch = binascii.a2b_hex(data[0][2:])
- if len(csetch) == 1 and 0x80 <= csetch[0]:
- continue
-
---
-cgit v1.2.3
-