summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStar Brilliant2015-06-16 02:26:54 +0800
committerStar Brilliant2015-06-16 02:26:54 +0800
commitfcaedc3edcdc05522b1d24c821056bdfc08a4643 (patch)
treefe863b60bb991ac85605d457dbd46a9634d23e90
downloadaur-lib32-sandbox.tar.gz
Initial import
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD30
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..01dba060b48f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = lib32-sandbox
+ pkgdesc = sandbox'd LD_PRELOAD hack (32-bit)
+ pkgver = 2.6
+ pkgrel = 1
+ url = http://www.gentoo.org/
+ arch = x86_64
+ license = GPL
+ depends = lib32-glibc
+ source = http://distfiles.gentoo.org/distfiles/sandbox-2.6.tar.xz
+ md5sums = 83c63d4959c0ebe89685b83f4bbd9f23
+
+pkgname = lib32-sandbox
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4b1120388596
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Contributor: Star Brilliant <echo bTEzMjUzQGhvdG1haWwuY29tCg== | base64 -d>
+
+_pkgbasename=sandbox
+pkgname=lib32-$_pkgbasename
+pkgver=2.6
+pkgrel=1
+pkgdesc="sandbox'd LD_PRELOAD hack (32-bit)"
+arch=('x86_64')
+url='http://www.gentoo.org/'
+license=('GPL')
+depends=('lib32-glibc')
+source=(http://distfiles.gentoo.org/distfiles/$_pkgbasename-$pkgver.tar.xz)
+md5sums=('83c63d4959c0ebe89685b83f4bbd9f23')
+
+build() {
+ cd "$srcdir"/$_pkgbasename-$pkgver
+ export CFLAGS="$CFLAGS -m32"
+ export CPPFLAGS="$CFLAGS -m32"
+ export PKG_CONFIG_PATH="/usr/lib32/pkgconfig"
+ ./configure --prefix=/usr --libdir=/usr/lib32 --sysconfdir=/etc --localstatedir=/var
+ make
+}
+
+package() {
+ cd "$srcdir"/$_pkgbasename-$pkgver
+ make DESTDIR="$pkgdir" install
+ rm -rf "$pkgdir"/{etc,usr/share,usr/bin}
+}
+
+# vim:set ts=2 sw=2 et: