summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLlewelyn Trahaearn2016-06-28 18:52:23 -0700
committerLlewelyn Trahaearn2016-06-28 18:52:23 -0700
commit6555fb4ff5d08f77c247d9542699e3fca8de21bb (patch)
treeb6dda5ba5c6e36a8635e517bb1ba84156e3b8090
parentcfac23db12510e32e56e642ec000c8b0aade480f (diff)
downloadaur-lib32-smpeg.tar.gz
Smack LDFLAGS environment variable so it respects system defaults.
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e45aa570a06d..92e2f54a5932 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -20,16 +20,16 @@ sha512sums=('SKIP')
build()
{
- cd "${srcdir}/${pkgname#lib32-}"
-
- # Override the defaults with 32-bit options.
+ # Modify environment to generate 32-bit ELF. Respects flags defined in makepkg.conf
export CC='gcc -m32'
- # GCC 6.1.1 introduced new behaviour that breaks things, using older standard allows successful build.
+ # GCC 6.1.1 introduced new behaviour that breaks things, using the previous standard allows for a successful build.
export CXX='g++ -m32 -std=gnu++03'
- export LDFLAGS='-m32'
+ export LDFLAGS+=' -m32'
export PKG_CONFIG_LIBDIR='/usr/lib32/pkgconfig'
export LIBS="-lX11"
+
+ cd "${pkgname#lib32-}"
./autogen.sh
./configure --prefix=/usr --libdir=/usr/lib32 --disable-static
make
@@ -37,7 +37,7 @@ build()
package()
{
- cd "${srcdir}/${pkgname#lib32-}"
+ cd "${pkgname#lib32-}"
make DESTDIR="${pkgdir}" install
rm -r "${pkgdir}/usr/"{bin,include,share}
}