summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2017-02-09 20:36:49 +0000
committerAntonio Rojas2017-02-09 20:36:49 +0000
commit88c0e1946f81699023ff16a9bf9c681239ac0298 (patch)
tree0e9b81cb5caca06f7475b79221e8d804390ced89
downloadaur-lib32-sni-qt.tar.gz
Drop from [multilib]
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD44
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8a8cad19ff42
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = lib32-sni-qt
+ pkgdesc = A Qt plugin which turns all QSystemTrayIcon into StatusNotifierItems (appindicators) (32-bit)
+ pkgver = 0.2.6
+ pkgrel = 6
+ url = https://launchpad.net/sni-qt
+ arch = x86_64
+ license = GPL
+ makedepends = cmake
+ makedepends = gcc-multilib
+ depends = sni-qt
+ depends = lib32-libdbusmenu-qt
+ depends = lib32-qt4
+ source = http://launchpad.net/sni-qt/trunk/0.2.6/+download/sni-qt-0.2.6.tar.bz2
+ source = http://launchpad.net/sni-qt/trunk/0.2.6/+download/sni-qt-0.2.6.tar.bz2.asc
+ validpgpkeys = 45C43F82329D77F384214CCABEED35A5EEE34473
+ md5sums = e84c66e776f7c22c961817387f618c81
+ md5sums = SKIP
+
+pkgname = lib32-sni-qt
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0d91fbbf654b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Florian Pritz <bluewind@xinu.at>
+# Contributor: Xiao-Long Chen <chenxiaolong@cxl.epac.to>
+
+# vercheck-pkgbuild: auto
+# vercheck-ubuntu: name=sni-qt, repo=utopic
+
+pkgname=lib32-sni-qt
+pkgver=0.2.6
+pkgrel=6
+pkgdesc="A Qt plugin which turns all QSystemTrayIcon into StatusNotifierItems (appindicators) (32-bit)"
+arch=(x86_64)
+url="https://launchpad.net/sni-qt"
+license=(GPL)
+depends=(sni-qt lib32-libdbusmenu-qt lib32-qt4)
+makedepends=(cmake gcc-multilib)
+source=("http://launchpad.net/sni-qt/trunk/${pkgver}/+download/sni-qt-${pkgver}.tar.bz2"{,.asc})
+validpgpkeys=(45C43F82329D77F384214CCABEED35A5EEE34473)
+md5sums=('e84c66e776f7c22c961817387f618c81'
+ 'SKIP')
+
+build() {
+ cd "sni-qt-${pkgver}"
+
+ export CC="gcc -m32"
+ export CXX="g++ -m32"
+ export PKG_CONFIG_PATH=/usr/lib32/pkgconfig
+
+ # XXX: Use the correct qconfig.h. This is probably not optimal, but it seems
+ # to work well enough.
+ export CFLAGS="$(pkg-config --cflags QtCore) ${CFLAGS}"
+ export CXXFLAGS="$(pkg-config --cflags QtCore) ${CXXFLAGS}"
+
+ cmake . \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DQT_PLUGINS_DIR=/usr/lib32/qt/plugins
+
+ make
+}
+
+package() {
+ cd "sni-qt-${pkgver}"
+ make DESTDIR="${pkgdir}/" install
+}