summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlchristian Eckert2016-07-14 17:34:46 +0200
committerCarlchristian Eckert2016-07-14 17:34:46 +0200
commitcd208656caff6876ce32ccddc75617813bef93a3 (patch)
treece29458732f9f7689d5974394383aab1e72156dc
downloadaur-libadios-git.tar.gz
initial
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD55
-rw-r--r--libadios-git.install3
3 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..75feec4c6dcf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = libadios-git
+ pkgdesc = ADIOS Adaptable IO system for simulations. The Adaptable IO System (ADIOS) provides a simple, flexible way for scientists to describe the data in their code that may need to be written, read, or processed outside of the running simulation.
+ pkgver = 1.10.0.r422.g084b08f
+ pkgrel = 1
+ url = https://www.olcf.ornl.gov/center-projects/adios/
+ install = libadios-git.install
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = git
+ depends = openmpi
+ depends = python2
+ depends = mxml
+ depends = gcc-fortran
+ source = libadios-git::git://github.com/ornladios/ADIOS.git
+ sha256sums = SKIP
+
+pkgname = libadios-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f59f7be9fa82
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# Maintainer: Carlchristian Eckert <carli-eckert at gmx dot de>
+
+pkgname=libadios-git
+pkgver=1.10.0.r422.g084b08f
+pkgrel=1
+pkgdesc="ADIOS Adaptable IO system for simulations. The Adaptable IO System (ADIOS) provides a simple, flexible way for scientists to describe the data in their code that may need to be written, read, or processed outside of the running simulation."
+url="https://www.olcf.ornl.gov/center-projects/adios/"
+install=$pkgname.install
+license=('BSD')
+arch=('i686' 'x86_64')
+depends=('openmpi' 'python2' 'mxml' 'gcc-fortran')
+source=("${pkgname}::git://github.com/ornladios/ADIOS.git")
+makedepends=('git')
+sha256sums=('SKIP')
+
+pkgver(){
+ cd ${pkgname}
+ # remove leading "v", then remove everything after the first "-"
+ # RELEASE=$(git describe --long --tags | sed 's/v//;s/-.\+//')
+
+ # take version directly from their version file, since that is what is reported internally
+ RELEASE=$(grep -o "ADIOS_VERSION \"[.0-9]\+\"" src/public/adios_version.h | sed 's/[^.0-9]//g')
+
+ # remove everything before the first "-", including the "-"; then replace remaining "-" with "."
+ REVISION=$(git describe --long --tags | sed 's/[^-]\+-//;s/-/./g')
+ echo ${RELEASE}.r${REVISION}
+}
+
+
+prepare() {
+ cd ${pkgname}
+ # replace all occurences of python with python2 to avoid using the default python3
+ find . -type f -print0 | xargs -0 sed -i -e 's/\(#\!\/usr\/bin\/env python\)/\12/' -e 's/python \(.*.py\)/python2 \1/'
+}
+
+build() {
+ cd ${pkgname}
+ ./autogen.sh
+ CFLAGS="$CFLAGS -fPIC" ./configure --enable-static --enable-shared --prefix=/usr/ \
+ --with-mxml=/usr \
+ --with-mpi=/usr \
+ --with-zlib=/usr
+ make
+}
+
+check() {
+ cd ${pkgname}
+ make check
+}
+
+package() {
+ cd ${pkgname}
+ make DESTDIR="${pkgdir}" install
+ install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
diff --git a/libadios-git.install b/libadios-git.install
new file mode 100644
index 000000000000..4bdbbf3f3be7
--- /dev/null
+++ b/libadios-git.install
@@ -0,0 +1,3 @@
+post_install() {
+ echo 'set the environment variable ADIOS_ROOT to be ADIOS_ROOT=/usr/ and the LD_LIBRARY_PATH to LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/lib'
+}