summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDušan Simić2021-08-22 15:27:50 +0200
committerDušan Simić2021-08-22 15:27:50 +0200
commit70ee4e8528c4a18ab488331633b9398ebdde3278 (patch)
treebbf4fc8ee9956755d657b1b1062b7c5ef6f7533b
downloadaur-libadwaita-health.tar.gz
Add all files
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD31
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..065b73d45654
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = libadwaita-health
+ pkgdesc = Building blocks for modern GNOME applications (version required by health)
+ pkgver = r1547.660d529
+ pkgrel = 1
+ url = https://gitlab.gnome.org/exalm/libadwaita
+ arch = x86_64
+ license = LGPL
+ makedepends = git
+ makedepends = meson
+ makedepends = gobject-introspection
+ makedepends = vala
+ depends = gtk4
+ provides = libadwaita
+ conflicts = libadwaita
+ source = libadwaita::git+https://gitlab.gnome.org/exalm/libadwaita.git#commit=660d529a6abb571fb592353f67d56915cb5abe54
+ md5sums = SKIP
+
+pkgname = libadwaita-health
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e0caa1e9c60b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg
+src
+libadwaita
+*.pkg.tar.zst
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5eda21c8bd05
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Dušan Simić <dusan.simic1810@gmail.com>
+
+_pkgname=libadwaita
+pkgname="$_pkgname-health"
+pkgver=r1547.660d529
+_commit=660d529a6abb571fb592353f67d56915cb5abe54
+pkgrel=1
+pkgdesc='Building blocks for modern GNOME applications (version required by health)'
+arch=(x86_64)
+url=https://gitlab.gnome.org/exalm/libadwaita
+license=(LGPL)
+depends=(gtk4)
+makedepends=(git meson gobject-introspection vala)
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("$_pkgname::git+$url.git#commit=$_commit")
+md5sums=(SKIP)
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ arch-meson "$_pkgname" build -Dgtk_doc=false
+ meson compile -C build
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja -C build install
+}