summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Bartels2015-08-29 17:01:42 +0200
committerPatrick Bartels2015-08-29 17:01:42 +0200
commit0ed77a4a7e04a1918ccfc4607310188879836107 (patch)
tree6a7a76220452e76c26d007177f799313137c6c69
downloadaur-libao-sndio.tar.gz
Initial commit
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD36
-rw-r--r--libao.conf2
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..68ac12078422
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = libao-sndio
+ pkgdesc = Cross-platform audio output library and plugins (with sndio support)
+ pkgver = 1.2.0
+ pkgrel = 1
+ url = http://xiph.org/ao/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = libpulse
+ depends = alsa-lib
+ depends = sndio
+ provides = libao
+ provides = libao-pulse
+ conflicts = libao
+ conflicts = libao-pulse
+ replaces = libao-pulse
+ backup = etc/libao.conf
+ source = http://downloads.xiph.org/releases/ao/libao-1.2.0.tar.gz
+ source = libao.conf
+ md5sums = 9f5dd20d7e95fd0dd72df5353829f097
+ md5sums = 2c170aaec57e5cd9ea84ab1e400786cb
+
+pkgname = libao-sndio
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..83af7eb4c3d0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Contributor: Patrick Bartels <pckbls@gmail.com>
+
+pkgname=libao-sndio
+_basepkg=libao
+pkgver=1.2.0
+pkgrel=1
+pkgdesc='Cross-platform audio output library and plugins (with sndio support)'
+url='http://xiph.org/ao/'
+arch=('i686' 'x86_64')
+license=('GPL')
+depends=('alsa-lib' 'sndio')
+makedepends=('libpulse')
+backup=('etc/libao.conf')
+conflicts=("libao" "libao-pulse")
+provides=("libao" "libao-pulse")
+replaces=("libao-pulse")
+source=("http://downloads.xiph.org/releases/ao/${_basepkg}-${pkgver}.tar.gz"
+ 'libao.conf')
+md5sums=('9f5dd20d7e95fd0dd72df5353829f097'
+ '2c170aaec57e5cd9ea84ab1e400786cb')
+
+build() {
+ cd "${srcdir}/${_basepkg}-${pkgver}"
+
+ ./configure \
+ --prefix=/usr \
+ --enable-alsa-mmap \
+
+ make
+}
+
+package() {
+ cd "${srcdir}/${_basepkg}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+ install -Dm644 "${srcdir}"/libao.conf "${pkgdir}"/etc/libao.conf
+}
diff --git a/libao.conf b/libao.conf
new file mode 100644
index 000000000000..abddf7593d49
--- /dev/null
+++ b/libao.conf
@@ -0,0 +1,2 @@
+default_driver=alsa
+dev=default